Jump to content

Landing Research Rocket Error and Building Disappearance

  • Branch: Live Branch Version: Windows Known Issue

So, for "research purposes" I build rockets in Sandbox mode and had my first set of two lift off (if I send another one, the colony is noted as lost).

Everything goes smoothly, for the first one but as the 2nd one lands and spawns the Data Banks, the game tells me on the right side:


"Error Occurred

Please restart game"

This Save is just before landing and before the error: Rocket Bugs.sav

Noteworthy is the endless cascade of data banks as well as that the gantry at least can not be extended.


Now, I saved and restarted the game, loaded the file and


same thing yet there are two differences: The cascade ends and Liam is sleeping midair.

So let's save, quit and load again! Rocket Bugs 3.sav

Everything seems fine there (except that they previously had Exosuits already, they are gone) but what if I try to unassign assign Liam after a bit of time or otherwise play with the Command Capsule? Another Error Occurs and even after save&load there is this:


moving a little more to the left and


it is back again, however it disappears when moving right again.

This can be seen in Rocket Bugs 4.sav


I hope this documentary is enough to find and destroy the game breaking error, if it helps, here is the save from before the liftoff and variations I tried:

Rocket Bugs 0.sav

Launching only the second rocket resulted in the error but no cascade after three cycles

Launching both at the same time (instead of delayed) had the same result after three cycles. 

Launching only the first to the asteroid of the second resulted in the error but no cascade after three cycles.

Launching only the second to the asteroid of the first resulted resulted in the error but no cascade after three cycles.

Extra Bug 1: The 2nd first Asteroid with Isoresin had before discovery 2 ??? Materials, after none and only Isoresin.

Extra "Bug" #2: Discovered Material  percentage is rolled on landing (Isoresin on tier 1.2 asteroid in 2&3 is 10%, #4 is 6% and #1 may very well be different)

Rocket Bugs 2.sav

Steps to Reproduce
Please use the provided saves as mentioned. ----- Save#1: Load, wait for the 2nd rocket to land and spawn Data Banks, see error. then save, restart ONI. ----- Your Save or Save#2: Load and see error, save again, restart. ----- Your Save or Save#3: Load, wait and reassign the (first) rocket, buildings will disappear and you get the error again. Save, restart. ----- Your Save or Save#4: Load, move to the left until buildings reappear, move right again. ----- Save#0: Launch the Alpha or Beta rocket to the first and right Carbon Asteroid (first tier)

User Feedback

Changed Status to Known Issue

Changed Redmine to https://redmine.klei.com/issues/4370

Thanks so much for the detailed repro steps and saves! 

  • Thanks 1

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...