Sign in to follow this  

Game overloads CPU and crashes


Meeps Dad
  • Branch: Live Branch Version: OSX Pending

So I never get around any sort of forum, but this is driving me mad and I'm really enjoying this game. (Just about to build my first petroleum boiler on live playthrough). So I'm at cycle 741, have 33 dupes in the base, and a decent amount of automation and shipping going on, although not even close to space age yet, map is maybe ~50% dug out. Only my 4th(?) or so base so no hate lol.

Anyway I load up the game it runs for a little bit (maybe 1 or 2 cycles) and then crashes and freezes. This started around cycle 700 and have managed to slowly trudge my way through to this cycle, but now it happens very quickly after I load up this file, doesn't matter how long I leave comp going for it stays frozen. The CPU overloads gets to over 100% (usually around 110/116?) when I check activity monitor. I've updated my OS to the latest version. I have 16gb of ram, and 2.2ghz quad core i7 processor. So my machine is pretty decently geared for this kinda thing. I don't know HEAPS about the tech stuff but I know enough about some of the basics.

As well I can run other save files fine, so is this indicative that something is up with this particular save file?? Idk maybe it's too big now, but I don't really wanna start another base knowing I'll just freeze again when I get to the level of complexity... and I haven't even launched a rocket! ALSO I run about 36 (mostly basic) mods, nothing that changes the game just all the little quality of life mods. Chained deconstruct, blueprint, dupe settings manager etc...

I'm having a lot of fun playing but just need some help so I can keep having a good time <3 x

MeepsDad

 

SYSTEM SPECS

Processor: 2.2 GHz Quad-Core Intel Core i7

Memory: 16 GB 1600 MHz DDR3

Graphics Card: Intel Iris Pro 1536 MB


Steps to Reproduce

This does not happen when the game autosaves, my autosave setting is every 10 cycles. It's very random, and I can't really reproduce it, I even had a stretch of 10 cycles (not correlated to autosave) right after I updated my OS where it ran perfectly!

Tried to find a pattern within this bug. The only correlation I could find was if I had a lot of chores queued up for the dupes it tends to happen MORE when it's like that. But not strictly when that was the case.

Sign in to follow this  


User Feedback


Looking at the attached log the chained deconstruction mod is throwing errors. Try disabling it and the other mods and see if the problem persists. Even the most basic mods could be causing issues.

  • Like 1
  • Thanks 1

Share this comment


Link to comment
Share on other sites

And no, it does not "overload" your CPU. What the ressource display is telling is, it uses more than 1 core, and because there is just 1 display for the entire CPU invalid values > 100% are combined displayed. 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now