Game hangs on launch

  • Branch: Live Branch Version: Linux Closed

When launching from Steam the game gets to the Klei logo, stays there for over a minute, and then crashes.  I have changed to the audio logging beta branch, changed back to the live branch, completely uninstalled and reinstalled, all to no avail. Renaming kplayerprefs.yaml makes no difference.  Renaming the prefs file (Unity prefs) results in the game showing all white with no logo (except for the audio logging branch, where its removal makes no difference).  Also, the game doesn't respond to the Steam client "stop" button.


Steps to Reproduce
Launch the game from Steam

User Feedback


Well now, this is odd.  I tried starting the game without Steam via running the binary OxygenNotIncluded from the command line.  It opened up an ONI window, launched Steam, opened up a second ONI window, and the game actually worked in the second window.  I quit from everything, restarted the Steam client, used that to launch ONI, and now it works fine.  I've since been unable to duplicate the bug, not matter what I do to the files in $HOME/.config/unity3d/Klei/Oxygen Not Included.

Oh well, at least now if someone else runs into this bug there'll be a known solution.

Share this comment

Link to comment
Share on other sites
.... ....

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now