Jump to content

Fresh ONI install, black screen

  • Branch: Live Branch Version: Linux Fixed

When installing ONI through Steam on a Linux machine for the first time, it will only display a black screen when you try to play.  This appears to be a new issue, since previously I was playing it just fine on my system.  I can repeat this bug with both Ubuntu and Arch distribution families.

I have also found a solution:  Apparently during install, the Unity3d prefs file for ONI sets the initial screen resolution to 1x1 pixel.  To resolve the problem:

  • Edit the file <home>/.config/unity3d/Klei/Oxygen Not Included/prefs
  • Alter the line:  <pref name="Screenmanager Resolution Height" type="int">1</pref> to <pref name="Screenmanager Resolution Height" type="int">1080</pref>
  • Alter the line: <pref name="Screenmanager Resolution Width" type="int">1</pref> to <pref name="Screenmanager Resolution Width" type="int">1920</pref>
  • Save the file
  • Re-start ONI.

There are no log files attached, as there are no errors involved.  I have found this error on 3 different machines running 3 different Linux variants (Mate, Mint, Manjaro).  It only applies to brand new installs.  If ONI was previously running on your machine and you reinstall, it will still work.

Steps to Reproduce
Freshly install ONI on a supported Linux machine. Uninstalling and re-installing does not work -- it has to be a fresh install. Try running ONI.
  • Thanks 1

User Feedback

A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Having just reimaged a system to Ubuntu last night, I can confirm I had the same issue and the same solution worked. The game would launch, black screen, go to white screen, audio would start perfectly fine, then black screen. I could hear the little menu animation noises happening but not do anything. Actually really glad someone already found out what was wrong, so cheers to that.

After changing the resolution as listed, launched again and worked as I had originally expected.

Share this comment

Link to comment
Share on other sites

Thanks so much @KittenIsAGeek for figuring that out! We've seen a number of cases of this; the log shows a resolution of 1x1 but we weren't sure where that number was coming from.

Now we're not sure where this setting in the prefs file is coming from but at least now we can hunt that down. Appreciate it!

Share this comment

Link to comment
Share on other sites

My suspicion is that the script that generates the prefs.ini file for Unity3d during the install of ONI is getting a bad value and passing that along in the settings.

Hunting down bugs that don't have errors is hard...

Share this comment

Link to comment
Share on other sites

Changed Status to Fixed

The game will detect and fix this error in the next major update. In the meantime, the solution posted here (modifying /.config/unity3d/Klei/Oxygen Not Included/prefs) will resolve the issue.

  • Thanks 1

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...