Deterministic hang after loading this save file


Heckeron
  • Branch: Live Branch Version: Windows Fixed

Was running on Windows when client hung halfway through cycle 152. Waited 20 minutes and eventually ended up forcible killing the client. Loaded the save and the client hangs a couple of frames after resuming the simulation. Loaded the same save on my Mac and the same issue occurs there too.

I'm not attaching my log files since this issue is deterministic on two separate platforms and it would take significant effort to anonymize the log file for public posting.

Beautiful Spacerock Cycle 152.sav.zip


Steps to Reproduce
Load the same with the current release version on either Windows or Mac. Resume the simulation. Cry.


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
Quote

significant effort to anonymize the log file for public posting.

What kind of info do you think the log file contains? The only user identifying thing it contains is your OS user name (path to user folder) which you can remove easily with find and replace. It also contains system specs but nothing identifying about that.

Edited by AlexRou

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now