No Run Can Be Completed (by abandoning, dying, or successful completion)


Rurude
  • Branch: Live Branch Version: Switch Pending

Every time I end the game (from the menu, death, or successfully completing a run), the screen will freeze, then go black, and will show the message that an error then crash back to the Switch main menu. This happens every single time. There is no way for me to finish a run. The videos I included below shows a Smith brawl run, first fight, ending in death and then the software crashes, and a Sal campaign run, fight in first quest, exit by menu+abandon run also ending the same error/crash.

((EDIT: I've added another video that shows a victory Sal brawl run that also ends in this error.))

The runs will stay on as an unfinished save. I can start it again but once I try to end it it will simply crash and show the message again.

Edit: I would like to add prior to the last switch update, I had been lucky enough not to encounter this issue until about a week or two before it was patched. After the patch, I did not encounter this issue again until some time had passed. It started occuring after I pause in the middle of a daily challenge, then completed the daily challenge AFTER it had already rolled over into a new one. Since then I have not been able to complete any run in campaign, brawl, or challenge.


Steps to Reproduce

1. Start a daily challenge.

2. Pause the daily challenge.

3. Complete the daily challenge in any way AFTER the daily challenge has rolled over to show a different daily challenge.

4. Start any run with any character.

5. End the run by death, abandoning the run from menu, or completing the run successfully.

Expected result: Error message and crash to switch menu screen.

 

 



User Feedback


Oh yes the exact same thing happened to me! I can't remember what I exactly did, but it happened after I did something in a daily. So I'm sure I did the same thing as you.

Share this comment


Link to comment
Share on other sites

Hi @Rurude and @Zuruas,

I'm investigating this currently but haven't been able to reproduce the issue with the steps provided. I have a few questions that will help guide further testing:

  1. Which patch version(s) have you seen this issue occur on?
  2. Did you fully close and restart the game at any point in those reproduction steps?
  3. Has the issue ever been resolved by anything other than a new patch release?
  4. How many runs do you have in your run history, and how many do you have active?

Thanks for your help, and apologies for the inconvenience!

Edited by skyjeremy
  • Thanks 1

Share this comment


Link to comment
Share on other sites
4 hours ago, skyjeremy said:

Hi @Rurude and @Zuruas,

I'm investigating this currently but haven't been able to reproduce the issue with the steps provided. I have a few questions that will help guide further testing:

  1. Which patch version(s) have you seen this issue occur on?
  2. Did you fully close and restart the game at any point in those reproduction steps?
  3. Has the issue ever been resolved by anything other than a new patch release?
  4. How many runs do you have in your run history, and how many do you have active?

Thanks for your help, and apologies for the inconvenience!

Hi @skyjeremy,

I unfortunately saw this too late. I was able to "fix" the issue by completely deleting my entire saved data and redownloading the game. However I can give you most of the information you ask for.

 

1. This occured in version 1.0.2. 

2. I fully closed the game at various points throughout, including deleting the game and redownloading it (before removing my save data).

3. I was able to resolve the issue by taking the nuclear option: deleting all saved data and using a fresh download of the game. I can now finish runs and progress.

4. I was not sure how many runs I had in my history, but at the time I had 3 active runs, all of them from the videos that I had uploaded.

 

Also, not sure if you saw it, I had to make another edit to the steps for reproducing, since the main cause seemed to be the daily challenge thing. I've put the steps again below for clarity's sake. Let me know if you need anything else from me.

Steps to Reproduce

1. Start a daily challenge.

2. Pause the daily challenge.

3. Complete the daily challenge in any way AFTER the daily challenge has rolled over to show a different daily challenge.

4. Start any run with any character.

5. End the run by death, abandoning the run from menu, or completing the run successfully.

Expected result: Error message and crash to switch menu screen

Share this comment


Link to comment
Share on other sites

Hihi! I've got the same bug. Runs won't end properly, instead crashing the game and booting me back to the home screen. 

 

My experience with Griftlands on Switch has been great! I avoided all the other bugs so far, I'm sure you guys can figure it out <3

Share this comment


Link to comment
Share on other sites
On 7/20/2021 at 9:59 PM, skyjeremy said:

Hi @Rurude and @Zuruas,

I'm investigating this currently but haven't been able to reproduce the issue with the steps provided. I have a few questions that will help guide further testing:

  1. Which patch version(s) have you seen this issue occur on?
  2. Did you fully close and restart the game at any point in those reproduction steps?
  3. Has the issue ever been resolved by anything other than a new patch release?
  4. How many runs do you have in your run history, and how many do you have active?

Thanks for your help, and apologies for the inconvenience!

@skyjeremy

I just saw this now, I apologize for the late answer!

1. 1.0.2

2. I do believe yes, I think it was late and wanted to do the rest of the daily tomorrow, after I finished the daily this issue occured. I can't remember if I was able to finish that specific daily tho. After the daily I highly doubt I closed the game in a next normal run

3. Not for me, and I tried various things, issue is still there. and I don't want to wipe my save data like op haha

4. In no point in my game I ever had more than 1 run active, even then I mostly finish the runs when I start them without pause, currently 79 runs in my history. Currently 0 active.

Share this comment


Link to comment
Share on other sites

I've also hit this error last night on my Nintendo Switch which is currently up to date both for the system and the game.

I thought it was a weird coincidence at first that when I died the game crashed (game encounters an error, turns off) and I was able to return to resume and take an alternate path and survive.

But then when I got to the end and beat what would have been the first playthrough as Smith, the game crashed when it was going to the experience gain portion (and thus the save state). So I played the final boss again, same path, crashed again at the same spot. Then I played a second time, crashed again at the experience gain. Then I tried to just abandon the run three times and it crashed each time when it should have gone to the experience page.

This is honestly going to be great for my productivity since I can't play beyond the final boss for Smith which I won't do til the game can end, but this is a major issue with the game.

Share this comment


Link to comment
Share on other sites

Hi, created an account because I was running into this bug on Switch also. PAL / Aus version if that makes a difference.

  1. Which patch version(s) have you seen this issue occur on?
    This issue first appeared in 1.0.2. I updated to 1.0.3 and still the same issue occurs.
     
  2. Did you fully close and restart the game at any point in those reproduction steps?
    I have fully closed the game and reopened many times (with an update inbetween) to no avail. I am not certain of the daily steps others have posted though. I have played dailys though if that helps determine the cause of the error.
     
  3. Has the issue ever been resolved by anything other than a new patch release?
    No
     
  4. How many runs do you have in your run history, and how many do you have active?
    I think I had two or three other active runs at the time. I deleted the other ones and retried, only to have the same problem. In terms of run history, I have 79 also (coincedence?)

Thanks for the great game Klei. Hoping to be able to continue playing after a fix

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now