Severe Lag Issue


Dorka
  • Pending

I updated the game last night, didn't get to play it til today and now i'm experiencing severe lag issues. I've never had issues with lag before, my connection had always been 3 bars, now it's always at 1 bar. I've made no change to my internet or my computer. I was just playing 2 days ago without any issue. Any help would be appreciated. 


Steps to Reproduce
Launch the game.


User Feedback


Update:

I decided to load one of the old worlds i had to see if i was experiencing the lag on those servers as well and.... I am not, it's full green bars across the way with no lag or frame skips. 

It seems the lag and frame skips comes when making hosting a new server. 

I also noticed when launching a new server, the animation screen from single player DS ( The world spinning with the hands on the side shaping it, etc etc.) plays and then is cut off by one of the vignettes, but the music is playing in the background like it's still running it.

Is this intended? A bug? How can i fix this? I uninstalled, reinstalled, and even reset my drivers. 

Share this comment


Link to comment
Share on other sites

Update: 

Upon further investigation of my own, i have learned that the lag only happens when playing as Wendy. I can play as every other character without any issue whatsoever, i have clean 3 bars across the way, but the second i load a game with Wendy, it goes straight to 1 bar and lags horribly. 

  • Thanks 1

Share this comment


Link to comment
Share on other sites

please join a game where you have experience the lag as Wendy and then attach your log file, which can be found here: \Documents\Klei\DoNotStarveTogether\client_log.txt
 

Share this comment


Link to comment
Share on other sites
14 minutes ago, ScottHansen said:

please join a game where you have experience the lag as Wendy and then attach your log file, which can be found here: \Documents\Klei\DoNotStarveTogether\client_log.txt
 

I hope this is the correct one. 

client_log.txt

Share this comment


Link to comment
Share on other sites

1) Please try starting a new world with all client and server mods disabled
2) Do you experience any of this while playing on someone else's server?
3) When hosting, does it make a difference if you are running with caves enabled?
4) Does it make a difference if Abigail is summoned or not?
5) Does the lag get any better while Abigail is at full health?

  • Thanks 1

Share this comment


Link to comment
Share on other sites

I have had the same issue and I've done a little testing. It seems like the food display mods are causing the issue. I've tried making worlds (as Wendy) with those mods (and some others I use such as Realistic Placements, Pausing etc.) and it starts to lag very quickly. But when I either make a new world or take away specifically the food display mods there is no lag at all.

Hope this helps ^^

Edited by Adrianfas
  • Thanks 1

Share this comment


Link to comment
Share on other sites
On 3/30/2020 at 3:19 AM, Adrianfas said:

It seems like the food display mods are causing the issue.

Thank you for tracking down which mod is causing the problem.

I've taken a look at it and the mod is conflicting with the way we are updating the Abigail's Flower action text. 

The mod also has the same issue when hovering the mouse over any item in your inventory and mashing buttons on the keyboard. When using a controller, opening the manage inventory menu (RT) will also cause massive frame rate and lag issues while an item has focus.

I will look into improving the situation with Abigail's flower, but in the mods current implementation, I would consider it a source of lag.

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now