Game Stuck at 60 FPS, DST ignores higher settings


Daniel86268
  • Closed

DST runs for me on 60 FPS independantly what I set the desired framerate to.

It kinda feels like the game plainly ignores the Refresh Rate Setting, since when I set it to a different Framerate and hit "Apply" it just goes back to the main screen as if I klicked "< back". If I go back into the settings it reverted that change. I can only forcefully apply that setting by also changing another setting at the same time. It still doesn't affect the actual framerate though, it just changes the number in the settings window.

My specs: i7 4790k, gtx 970, 32gb RAM, 120hz 1080p Monitor.

Latest Nvidia drivers, Windows 10, the monitor is running at 120hz, other Games run at 120hz as well without issues.

I also checked the client.ini file in my user directory, it also says that it's set to 120 FPS. I tried deleting it as well, so a new one got generated, set it back to 120 FPS, applied to the file, in game no change.

Tested with and without mods, and with and without the threaded render and the threaded physics.


Steps to Reproduce
Grab a 120hz Monitor (or any monitor with more than 60hz) and a PC that has enough processing power to handle DST at more than 60Fps, and try to change the setting/reach more than actual 60 Fps in game.


User Feedback




Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now