Jump to content

Much help needed with custom character

Recommended Posts

So, a long time ago when I got into DST I started making a custom character. I'd done a lot of the basic legwork but had a couple of problems getting it to work.

Recently I've wanted to finish the character so I can get back into the game. but it was so long ago I can't remember most of the details.
I was trying to go over what I've done and refresh modding in my mind so that I could post about it again and see if I could fix the problems with my character.

But before I even do that, I had another problem loading the game.
This is with ONLY the custom character on, I get this error screen when trying to enter the world with that character.


I'd wager this is because the file I was working on is pretty old, and I haven't been on the game in a while.

Can anyone help me get around this problem first of all so I can actually look into the other problems? XD

Link to comment
Share on other sites

People will be able to help you more if you give more informations. In this case : copy the log (just in case there is more information in it), attach your mod.

Also, are you using a code to give an item to your character at spawn or something like this ? If yes, copy this code too.

Link to comment
Share on other sites

Thanks @Lumina.

I didn't include much else because I wasn't sure what files are relevant. As I mentioned I don't rememebr much about what I was doing or how modding happens since its been a while.
I don't think I had included any code but maybe I did. Could it be that I'd tried to give my character an item from another mod?
I assume I have to provide the mod in zip form.
Didn't know about there being a log either, I'll find that using the guide you provided

There, attached the files, hope it's all I needed.
It hadn't occurred to me before you mentioned it, but it is likely that I did try to include an item from another mod, and sicne I was starting with ONLY mine in an attempt to keep it clean, I broke it :3
I just didn't know where in the files the part with the mod item would be. like I said it's been a while... I am ALL rust.
While you look these over, I'll turn on the other mods I think it could include and try loading again





Link to comment
Share on other sites

1 minute ago, Lumina said:

Ok, this is good to know. There is a way to add a check to verify if another mod is enabled, so you can ensure compatibility between two mods.

But i don't remember it at the moment.

That's okay. It sounds like that would be better for me to look into later on anyway. For now I want to try and make sure I have the graphics in order, figure out how to set up custom skills and all that.
The actual problems I wanted to work on were
A) the tail of the character being offset from where it's supposed to be
B) white anti-aliasing edge around the character (at least when zoomed out)
But I think those topics are more relevant elsewhere. I can probably find existing topics on them

Link to comment
Share on other sites

Having another problem today
Not getting the same error as before (unless I forget to turn that other mod character on :P), but the game is stuck on a screen before entering the game

i was trying to set up a game to finally play for a change but needed to start a vanilla game, then turn on my character, then turn on every mod I want one at a time.

but after getting on my character it's already stopped DX
So what happens is after clicking to enter the world, it has a screen that is a shot of the woodland and not the 'characters falling into the portal' screen. It just stays on this view of the woodland. I really don't know what's happening here since I am not receiving an error message, but I left it for like 20 minutes to make sure it wasn't just taking a while.


The only things I've done since getting in to the game with the character last, was continuing to try and fix the missplaced tail. I made sure all was in place on Spriter and then edited the .xml files in the exported zip just to make sure they were all using the right co-ordinates. They were. So I don't think I even changed anything?
I did delete the character folder in the Anim folder so that the recompiler would... recompile them XD

Hope that provides some help. Attaching the log and mod itself.


Okay so I deleted ALL the zips in the Anim folder and then ran the recompile manually (rather than loading the game) and somehow it's working now :/
Still wouldn't mind some second opinions onto why this happened



Edited by Temakixai
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...