Jump to content

Custom Character launch freezing, invisible character animation model (Various other issues)

Recommended Posts

Hello everyone, recently as an avid player of Don't Starve Together I decided to try and make a mod. I had been originally using this tutorial 

which was fairly understandable, however as a beginner I am facing an array of challenges thus far, and I cannot find the solution to them


- Character Portrait not appearing

- Character model being invisible

- Launching a server, and then picking the character never loads, it doesn't freeze though, just never loads in

- Proper Texture alignment

If anyone could help out on these issues, I would be very grateful, and if there's any pointers I would appreciate those too. Additionally, if it's required of me to post more information, I would gladly do so.



Link to comment
Share on other sites

Yes, at the moment it will be hard to help without seeing the mod. But before i suggest you to verify that you have all the name right in the file. Meaning : you renamed all that should be renamed, with names in the right format, and not touched the things that shouldn't be renamed. Because lot of errors come from this.

Link to comment
Share on other sites

did you replaced the "ESC_TEMPLATE" by "NAME", the "esc_template" by "name" ? Did you keep the esc_template name when it was needed, or did you replace it all ? Because as far as i know not everything is to replace and case is important.

(Sorry can't look at mod now)

Link to comment
Share on other sites

From my point of view, the tutorial said to replace all ESC_TEMPLATE and estemplate by the character name in the different sizes, delthea, and DELTHEA. However, I could be wrong, I'll check with the original file, it could be an uppercase issue

Link to comment
Share on other sites

When I tried renaming the files to try something different, I would get errors such as this



Furthermore, I tried using the original template mod, which worked fine on my end. I tried tinkering with some textures; such as the portrait, however it didn't show up, it was blank similar to the listed problems on the first post

Screenshot of the portrait not working







Edited by TheReaper.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...