Bug - strange problems with restarting checkpoints in "A Change in Course" level


Recommended Posts

I would like to report some weird problems with restarting checkpoint in "A Change in Course" level (that level, where you have to open vents to leak gas) in NG+ mode. I was trying to maximize my score using equipment cache and checkpoints very often.

In short, I killed first guard. Then, I was distracting, disabling and so on second and third guards, using equipment cache and saving game passing through checkpoints very often. Then I hidden dead body of first guard behind these doors: http://steamcommunity.com/sharedfiles/filedetails/?id=974758407

Thanks to that, I get oblivious bonus (my first time ^^) using distractions item on second and third guards. Then I saved game by passing through checkpoint and was trying to kill second and third guards, but I was detected so I restarted checkpoint few times. But after some restarting checkpoint I found that first guard is alive! It looks that game restarted some of my older checkpoints. I restarted checkpoint again. It helped a little - now first guard was dead, but his body magically disappeared! (Second and third guards was still alive.) Body of first guard should be behind doors where I get oblivious bonus before restarting checkpoint, so I get frustrated that I cannot repeat what I have done before to get oblivious bonus. I killed second and third guards and progress game by going to next checkpoint. Then I decided to stop playing. I only checked that my progress was saved by checking that after restarting checkpoint everything is fine. I exit a game and I made copy of save file which I am sending as an (first) attachment.

Next day I run game again, this time enabling logging option. But when I continued game, body of second or third guard disappeared (it was hidden behind doors on screenshot). I made another copy of save file. I am sending that copy and logs also (second and third attachment). I cannot find any .MDMP file in "bin" folder - there are only .dll files and one .exe file.


Here is detailed description of what exactly happened:

All that happened was next to first vent on the right from elevator's shaft after leaking gas in basement. It is phase of game, where you have to open at least three vents. There are two rooms next to first vent on the right: first room with one guard (I call him first guard) and second room with two guards (I call them second and third guards, you can see them on screenshot to which I sent link before). Behind second room there is vent with checkpoint (I call it forth checkpoint). There are three checkpoints in elevator's shaft: first checkpoint at the level of basement, second checkpoint at level where first, second and third guards are and third checkpoint at level of equipment cache. Here is chronological sequence of what happened:

1. I was using equipment cache.

2. I go down via elevator's shaft to first checkpoint.

3. I return to second checkpoint to have fun with first guard.

4. I get many bonuses from first guard, by returning to equipment cache often (passing through second and third checkpoint in that process) and then I killed first guard and left his body where he was (maybe I was restarting checkpoints few times in that step).

5. I get many bonuses from second and third guards, by returning to equipment cache few times (maybe I was restarting checkpoints few times in that step).

6. I took body of first guard and hidden it behind doors in second room (I get "Body hidden" bonus).

7. I used some distraction bonus to make second and third guards pass next to doors with hidden body (I get "Oblivious" bonuses).

8. I returned to equipment cache to take terror darts (I am little unsure about that, maybe it was before step 6.).

9. I tried few times to use terror darts on both guard, but I was failing to do that.

10. I restarted game trying to do step 9. few times. After some restart, I found that I am next to first checkpoint (strange).

11. I go to second checkpoint and I saw that first guard is alive (very strange).

12. I restarted checkpoint (maybe I was roaming before that, triggering some checkpoints). After restart, I was next to second checkpoint. First guard disappeared. I couldn't find his body (I think I was looking for his body carefully, there is little chance that his body was somewhere).

13. I made screenshot of second room (I gave link to that screenshot before). As you can see, there is no body behind doors.

14. I go to forth checkpoint using mark of serenity (I think I used equipment cache before 14).

15. I go back to second room and maybe to equipment cache.

16. I killed second and third guard (I don't remember if I was restarting checkpoints).

17. I go to forth checkpoint.

18. I restarted checkpoint - I was still next to forth checkpoint (I am not sure if I move then somewhere).

19. I exit game.

20. I did copy of save file from 214560 folder from Steam folder (it is first "savegame.sav" file in attachment).

21. I enabled logging and run game again.

22. When I continued game I found that body of second or third, which was hidden behind doors from screenshot I gave link to, disappeared.

23. I exit game.

24. I did copy of save file again (it is second "savegame.sav" file in attachment) and copy of logs ("aggregate.log" file in attachment).





EDIT: Steps from 22. were wrong, now should be fine.


EDIT2: I did some testing after posting this post. It looks that bodies hidden behind doors on screenshot that I gave before disappear after restarting checkpoint.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.