Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

Ktei

[RESOLVED] Game doesnt start (DirectX is required to play)

Recommended Posts

Ktei    1

Greetings. I have trouble launching the game, after 2 hours of gameplay; at start, it says "Direct X is required to play Mark of the Ninja (KGraphics::initialize()failed)

I tried the DX setup in the game folders; I tried updating my video card driver. I tried reinstalling the game. No success.

DXdiag linked to it.

Thanks in advance, and by the way, it is a great game!

Gabriel

 

DxDiag.txt

 

P.S.: Just realised that my DxDiag is in french. If you need help translating, feel free to ask!

Share this post


Link to post
Share on other sites
JanH    5,206

If you haven't restarted your computer since upgrading to Windows 10 (or updating your Windows 10 OS), you could try that. Alternatively, you may want to try installing, or re-installing the latest drivers for your graphics card.

Should the issue persist, you can also try adjusting Windows compatibility settings on the game executable to Windows 7. (Steam\steamapps\common\mark_of_the_ninja\bin\game.exe)

Right click on "game.exe" > choose Properties > Compatibility Tab > "Run this program in compatibility mode for.... > choose Windows 7

Share this post


Link to post
Share on other sites
Ktei    1

I updated  (again) the driver. It now works! Thanks!

Sorry for the delay, I was sure I was following the thread...

 

Share this post


Link to post
Share on other sites