Getting new overworld instead of caves, how to fix it?


Recommended Posts

Hello,

 

on my dedicated server, when I try to enter cave through sinkhole, I get transfered to another world (separate map, but still on surface) instead of cave. What do I do wrong? I looked into this for some time, but I have no idea, really. I attach logs, settings and worldoverride files in respectable folders. Please help :-)

 

Another question: if the issue above is fixed, can I load caves to my save without having to reset my server? I would love to keep my progress on surface.

 

Big thanks in advance!

Caves.zip

Overworld.zip

Link to comment
Share on other sites

Unfortunately it didn't work for me :( space or no space, works the same.

I tried to add some additional stuff to settings, but still getting same result.

 

EDIT:

 

I found the solution in "worldgenovveride.lua with the new post-Caves settings" sticky, that is:

 

 

The reason that happened is because of two things together:

1) preset = "DST_CAVE"

This makes it load the "cave" world type, which includes pits instead of waves, earthquakes, and a few things like that.

2) task_set = "default"

This makes it load the normal above-ground biomes and regions.

So the combination of the two is a "forest in the caves" kind of thing. Interesting!

Meaning my worldgenovveride.lua in cave server's files should include:

misc = {

task_set = "cave_default",

}

Now just trying to restart caves without touching my overworld save, any ideas?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.