Jump to content

Caves portals register as "ACTIVE" but Overworlds as "INACTIVE"


Recommended Posts

I'm using the preconfigured servers, and everything seems to work fine so far, except the Overworld cave portals seem to not want to be set as active, even though the "available" line says true.

 

Overworld:

[00:00:12]: [SHARD] Slave 'caves(2529421124)' connected from [LAN] IP: 127.0.0.1[00:00:12]: [SHARD] Slave 'caves(2529421124)' ready![00:00:12]: World '2529421124' is now connected	[00:00:12]: Validating ID 1: status: INACTIVE world: 2529421124 (auto) available: true recieves: 1 (disabled by prefab)	[00:00:12]: Validating ID 2: status: INACTIVE world: 2529421124 (auto) available: true recieves: 2 (disabled by prefab)	[00:00:12]: Validating ID 3: status: INACTIVE world: 2529421124 (auto) available: true recieves: 3 (disabled by prefab)	[00:00:12]: Validating ID 4: status: INACTIVE world: 2529421124 (auto) available: true recieves: 4 (disabled by prefab)	[00:00:12]: Validating ID 5: status: INACTIVE world: 2529421124 (auto) available: true recieves: 5 (disabled by prefab)	[00:00:12]: Validating ID 6: status: INACTIVE world: 2529421124 (auto) available: true recieves: 6 (disabled by prefab)	[00:00:12]: Validating ID 7: status: INACTIVE world: 2529421124 (auto) available: true recieves: 7 (disabled by prefab)	[00:00:12]: Validating ID 8: status: INACTIVE world: 2529421124 (auto) available: true recieves: 8 (disabled by prefab)	[00:00:12]: Validating ID 9: status: INACTIVE world: 2529421124 (auto) available: true recieves: 9 (disabled by prefab)	[00:00:12]: Validating ID 10: status: INACTIVE world: 2529421124 (auto) available: true recieves: 10 (disabled by prefab)	

Caves:

[00:00:12]: [SHARD] Sending slave information to master...[00:00:12]: [SHARD] Registering in lobby as a slave server...[00:00:12]: Sim unpaused[00:00:12]: [SHARD] Registering portal ID #1	[00:00:12]: Validating ID 1: status: INACTIVE world: <nil> (auto) available: false recieves: 1	[00:00:12]: [SHARD] Registering portal ID #2	[00:00:12]: Validating ID 2: status: INACTIVE world: <nil> (auto) available: false recieves: 2	[00:00:12]: [SHARD] Registering portal ID #3	[00:00:12]: Validating ID 3: status: INACTIVE world: <nil> (auto) available: false recieves: 3	[00:00:12]: [SHARD] Registering portal ID #4	[00:00:12]: Validating ID 4: status: INACTIVE world: <nil> (auto) available: false recieves: 4	[00:00:12]: [SHARD] Registering portal ID #5	[00:00:12]: Validating ID 5: status: INACTIVE world: <nil> (auto) available: false recieves: 5	[00:00:12]: [SHARD] Registering portal ID #6	[00:00:12]: Validating ID 6: status: INACTIVE world: <nil> (auto) available: false recieves: 6	[00:00:12]: [SHARD] Registering portal ID #7	[00:00:12]: Validating ID 7: status: INACTIVE world: <nil> (auto) available: false recieves: 7	[00:00:12]: [SHARD] Registering portal ID #8	[00:00:12]: Validating ID 8: status: INACTIVE world: <nil> (auto) available: false recieves: 8	[00:00:12]: [SHARD] Registering portal ID #9	[00:00:12]: Validating ID 9: status: INACTIVE world: <nil> (auto) available: false recieves: 9	[00:00:12]: [SHARD] Registering portal ID #10	[00:00:12]: Validating ID 10: status: INACTIVE world: <nil> (auto) available: false recieves: 10	[00:00:12]: [SHARD] Slave is now ready![00:00:12]: [SHARD] Registering in lobby as a slave server...[00:00:12]: World '1' is now connected	[00:00:12]: Validating ID 1: status: ACTIVE world: 1 (auto) available: true recieves: 1	[00:00:12]: Validating ID 2: status: ACTIVE world: 1 (auto) available: true recieves: 2	[00:00:12]: Validating ID 3: status: ACTIVE world: 1 (auto) available: true recieves: 3	[00:00:12]: Validating ID 4: status: ACTIVE world: 1 (auto) available: true recieves: 4	[00:00:12]: Validating ID 5: status: ACTIVE world: 1 (auto) available: true recieves: 5	[00:00:12]: Validating ID 6: status: ACTIVE world: 1 (auto) available: true recieves: 6	[00:00:12]: Validating ID 7: status: ACTIVE world: 1 (auto) available: true recieves: 7	[00:00:12]: Validating ID 8: status: ACTIVE world: 1 (auto) available: true recieves: 8	[00:00:12]: Validating ID 9: status: ACTIVE world: 1 (auto) available: true recieves: 9	[00:00:12]: Validating ID 10: status: ACTIVE world: 1 (auto) available: true recieves: 10	 

I guess it's an issue with registering the portal IDs? But It seems to work in the end for the caves, so I'm not sure what exactly is going wrong.

Link to comment
Share on other sites

  • Developer

I should maybe change the message here to be more clear; in this case the portal is inactive because it hasn't been mined yet. The "available: true" is actually the part that lets you know the other world has successfully linked. Sorry about the confusion.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...