failed to connect to a friend's host game


Recommended Posts

Hello everyone,


I need help, my game (Don't Starve Together) is crashing when I try to connect to my friend's host game.


The error happen always at the same point after the "Connecting..." screen disappear, just before the character selection


The error:


[string "scripts/saveindex.lua"] :109: SaveIndex:GetSaveData: Load failed for file [client_temp/server_save] Please try joining again.

LUA ERROR stack traceback:

    =[C]:-1 in (global) assert © <-1--1>

    scripts/saveindex.lua:109 in () ? (Lua) <106-125>

    =[C]:-1 in (method] GetPersistentString © <-1--1>

    scripts/saveindex.lua:106 in (method) GetSaveDataFile (Lua) <105-126>

    scripts/gamelogic.lua:764 in (upvalue) DoLoadWorldFile (Lua) <756-765>

    scripts/gamelogic.lua:876 in (upvalue) DoLoadWorldFile (Lua) <827-904>

    scripts/gamelogic.lua:915 in (local) complete_callback (Lua) <907-916>


When I host the game, my friend can join me in....but it isn't convenient for me (that's my first time in Starve)


Must I uninstall and reinstall the game?


Thanks for the answers




Link to comment
Share on other sites

Firstly, I'd like to point out that this subforum is for:

  1. Don't Starve (The base, singleplayer game)
  2. Modding

So you should probably post this in a DST subforum.


Secondly, the error is not specific enough to divine it's cause. I suggest you find a third party to try and connect to your friend's server, and see if they can. (This will determine if it is you or him with the issue)


Are you hosting through the in-game method, or a dedicated server? (Can he get in?)


If you have the time, I do suggest reinstalling, which may be a much quicker way of resolving the issue than puzzling it out. (If it works)

Link to comment
Share on other sites

I have had the same problem. It happens with trying to connect to anyone's server. If I host the server, other people can connect, but their version of the world is incorrect (biomes are different, they walk on water, etc). I have uninstalled and reinstalled the game already but error is still the same.

Link to comment
Share on other sites

Case Solved,


My new (and terrible) Firewall blocked the game when I attempted to join the hosted game.


If, like myself, you have the Bitdefender antivirus/firewall software, then put Don't Starve into the "trusted app" of the firewall settings.



if not, turn off your firewall and test if it works (don't forget to turn On again your firewall right after the test(highly recommended)).


then if it worked, you must look to your firewall settings to add the game into the trusted app or something like this. If the test didn't work that only mean that's not a firewall issue....




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.