[Gameplay] - Giants spawned in 'no giants' mode


Recommended Posts

Bug Submission:

Category: Gameplay

Issue Title: Giants spawned in "no giants" mode

Issue Description: I started a new dst game recently. I selected to start a LAN game so I could check out the new features on my own but I didn't want the giants so I selected the "no more giants" present. My settings are in the box below. I had died and respawned when I got back to my base Deerclops spawned and killed me again. I think it was around world day 28. I was under the impression that the preset would turn off the giants spawning and return the seasons to normal but maps would still include the expanded items, bioms and tech trees (which were all present in my game). I even double checked to make sure I had selected the "no giants" preset and it was selected. If the preset is not supposed to turn off the giants please make one that does.

I really enjoy this game although i'm not good at it. Please keep up the good work and expand it. :D

Steps to Reproduce: These are the settings I selected:


2 player

Wilderness Mode

no more giants preset

(I left everything as default to the preset except I changed the map size to Medium and the "land branch" setting to Least)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.