Trouble with dedicated server


Recommended Posts

Hi, I am fairly new to hosting dedicated servers, the problem I am running into is that friends can see my dedicated server but when they try to join it states that the server is not responding. I am able to join it as is anyone on the local area network. I have not set it to LAN mode.

During the server boot I do notice an error in the cmd line window:

AddPortMapping(10999, 10999, 192.168.1.100) failed with code 718

 

I do not know if this has anything to do with my issue but that error is, as far as I can tell, saying that the port is in use by another client or program. As far as I know, nothing else is using that port and the only IP address with that port forwarded is the one in question.

Can anyone help me with this?

Link to comment
Share on other sites

Thank you for the reply.

There are no duplicate instances of the server running in the task manager. I also forgot to mention I am using the Don't Starve Together Dedicated Server tool in steam to run this.

Link to comment
Share on other sites

@Silvais,

 

your dedicated server though a static IP address?

your static IP address is added in the NAT of the router with the port of your server?

 

example:

 

150203051402647288.png

 

I havn't tried that yet, I will try it tomorrow after work. Thank you for the suggestion.

 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.