[General] - Steam Must Be Running to Play This Game


Recommended Posts

Bug Submission:

Category: General

Issue Title: Steam Must Be Running to Play This Game

Issue Description: This is a huge annoyance that has been going on for a couple of months. Whenever I try to launch DST, I get this popup saying "Steam Must be running to play this game (steamAPI_init() failed)"

Its really annoying, at I have done about everything under the sun to try to fix this. Let me list all I recall trying to do;

Restarting steam, verifying integrity of game cache, reinstalling, browsing MULTIPLE threads about other games with this issue, deleting mods, opting in and out of beta, disabling background applications, and flushconfig. That's about all I remember.

I bought this for my friends and I to get in on the fun early, and its kind of hard to do that when my game doesn't work at all. Any help is appreciated, but don't give snarky comments. (Like "It's a beta m8", which I assume I'd get a lot)

Steps to Reproduce: I recently downloaded the pixelvision steam skin, but after removing that the problem still persisted.

Link to comment
Share on other sites

Before I post all that crud, I forgot to add one detail.... I think. Anyways, the game USED to work, if I DID forget to add that. Okay.


Disabled mods, didn't work.


Windows 8.1


Tried comp mode, didn't work.



System Manufacturer: Acer

       System Model: Aspire V3-571
               BIOS: V2.02
          Processor: Intel® Core i5-3210M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
             Memory: 6144MB RAM
Available OS Memory: 5960MB RAM
          Page File: 2339MB used, 4579MB available
        Windows Dir: C:\WINDOWS
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: Using System DPI
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.03.9600.17415 64bit Unicode
Sorry if I didn't paste enough or too much, computers really aren't idiot proof.
Link to comment
Share on other sites

Computers are idiot proof. The more I know the more chance I have of breaking the computer. From what I have found.




Have you recently updated any drivers?

Did you recently make any changes to DST?


Have you tried noting down, then unsubscribing from all the mods. uninstalling DST. Backing up then deleting any folders that are left, if any. Then re-installing just DST.

Link to comment
Share on other sites

  • Developer

I think you're suffering from the same Steam client problem as described in the Mac article I linked.


Follow the steps in this Steam support page: https://support.steampowered.com/kb_article.php?ref=3134-TIAL-4638 It describes how to solve the problem on windows as well as other platforms.


Give this a try and let me know if it works.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.