[General] - gamepad support (linux)


Recommended Posts

Bug Submission:

Category: General

Issue Title: gamepad support (linux)

Issue Description: Hi,

Apologies if this has already been reported, I could not see it in your forum.

Dont starve together runs well for me under lubuntu 14.10 via steam, however when I try and use a xbox 360 gamepad the d-pad fails to register in game, leaving me unable to manipulate items in my inventory in accordance with the directional popups on screen. This is despite the sticks and face buttons all working correctly. I am also unable to remap onto the d-pad in the settings menu.

I believe the d-pad is working as it functions correctly both in steam and in other games (as well as with the xbox 360). Currently I am playing with a touchpad and keyboard, however this is not ideal for me given my lounge setting.

Any help would be most appreciated.


Steps to Reproduce: load game under linux via steam with xbox 360 pad attached.

Link to comment
Share on other sites

  • Developer

Hi radical5,


Are you using a wired or wireless 360 gamepad, and are you using any special driver? Does the game report it as an xbox joystick in the controller screen? Have you tried resetting the controller mappings to default settings?


Under Ubuntu 14.10 (64 bit) I'm able to use the d-pad on a 360 wired gamepad without any problems, so I need more information to try to resolve your issue.


Note that we only officially support Ubuntu for linux. I'm wondering if lubuntu may have a somewhat different xbox driver built into it.

Link to comment
Share on other sites

I recently ran into this issue as well. For anyone else who comes across this post, I provide simple instructions below for a fix that worked for me and might work for you.



I was using a wireless xbox 360 controller with the default xpad module on a 64-bit Linux system and the latest (as of the date of this posting) version of DST Beta. The controller showed up correctly as an xbox controller under game settings, and the game even correctly displayed the dpad and other xbox icons, but when I attempted to use the dpad during gameplay, the game did not respond. As the OP states, all other buttons work correctly -- it's just the dpad that doesn't seem to work, which makes interaction with inventory items impossible.


Also, when I attempted to remap the dpad buttons under "controls," the game froze every time. Choosing the gamepad defaults did not fix the issue, either.



I managed to get my dpad to work by removing the xpad module and installing xboxdrv, which I set to mimic the xpad settings. Notably, setting xboxdrv to mimic the wireless settings (e.g. xboxdrv --mimic-xpad-wireless) only replicated the original issue! Leave off the -wireless at the end to mimic the appropriate wired settings and the dpad should work fine. Good luck!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.