Jump to content

Server Token not working on Debian

Recommended Posts

Hey guys,


I have some trouble launching a DST server on my dedicated server.

I successfully installed it with steamcmd but I can't configure the settings.ini and server_token.

May be you guys can help me.


I included my logs.

As you can see, the server recognised the server_token but doesn't seem to connect to the authentification servers.


Thank you,



steam@sd-26350:~/DST/bin$ export LD_LIBRARY_PATH=/home/steam/lib_DSTsteam@sd-26350:~/DST/bin$ ./dontstarve_dedicated_server_nullrendererStarting UpVersion: 129194Don't Starve Together: 129194 LINUXBuild Date: 2015-03-05_11-21-22Parsing commandlineCommand Line Arguments:THREAD - started 'GAClient' (4139100992)HttpClient::ClientThread::Main()ProfileIndex:10.80Network tick rate: U=15(2), D=0Network tick rate: U=30(1), D=0OnLoadPermissionList: /home/steam/.klei/DoNotStarveTogether/save/blocklist.txt (                                                                          Failure)OnLoadPermissionList: /home/steam/.klei/DoNotStarveTogether/save/adminlist.txt (                                                                          Failure)Server token retrieved from: server_token.txtcGame::InitializeOnMainThreadRenderer initialize: OkayAnimManager initialize: OkayBuffers initialize: OkaycDontStarveGame::DoGameSpecificInitialize()THREAD - started 'GAClient' (4121934656)HttpClient::ClientThread::Main()THREAD - started 'GAClient' (4131384128)HttpClient::ClientThread::Main()THREAD - started 'GAClient' (4133485376)HttpClient::ClientThread::Main()THREAD - started 'GAClient' (4129282880)HttpClient::ClientThread::Main()FMOD Error: An invalid object handle was used.GameSpecific initialize: OkaycGame::StartPlayingLOADING LUADoLuaFile scripts/main.luaDoLuaFile loading buffer scripts/main.luascripts/main.lua(167,1) running main.lualoaded modindexModIndex: Beginning normal load sequence for dedicated server.FMOD Error: An invalid object handle was used.LOADING LUA SUCCESSPlayerDeaths could not load morguecould not load profileloaded profilebloom_enabled   falseloaded saveindexOnFilesLoaded()OnUpdatePurchaseStateComplete        Unload BECould not unload undefined prefab 0x3edae42e (multitool_axe_pickaxe)(...)Could not unload undefined prefab 0x427b5b39 (shatter)        Unload BE done        Load FE        Load FE: doneModIndex: Load sequence finished successfully.Reset() returningDownloadMods(0)CURL ERROR: connect() timed out![0] Account Failed (6): ""!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Your Server Will Not Start !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!If you wish to run your server without authenticationOr if you wish to use your server for a LAN gameYou must run it in 'lan mode'Add the command line argument -lanTo generate a server_token from a game client, open consoleopen console with the tilda key (~)Type: TheNet:GenerateServerToken()
Link to comment
Share on other sites

Hi @Flamby,


well im on debian and it's works for me, so i can help you




so your servertoken.txt is here right?






in your server_token.txt look like this?





Link to comment
Share on other sites

Yep it's in this directory.

It's in this format but there's 2 blank spaces at the end of my server_token.txt .

Do I have to keep them ? or I have to remove them?


Thank you for the quick answer.

Link to comment
Share on other sites

Hmmm I tried a clean install with a minimal settings.ini and a new server_token and it worked like a miracle.


I had some special character on my old server_token, now in the new (and working) server_token, there's only letters and numbers, if that helps.


Thank you again :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...