Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

CraftalGlory

Having some issues on linux

Recommended Posts

I got the software to work at home in my windows machine. 

But on my linux dedicated server I am having some issues getting the script to run.

 

 

When I run the script as follows there is simply nothing happening.

http://i.snag.gy/I4Nyc.jpg

Am I missing something?

 

King regards, 

CraftalGlory

 

 

Share this post


Link to post
Share on other sites
TonyV    9

What happens if you run it without using screen?  That is, just run ./dontstarve_dedicated_server_nullrenderer from the bin directory directly on the command line?

 

Share this post


Link to post
Share on other sites
G4E    5

On your screenshot, you forgot to put the && between :

 

cd /home/dontstarve/SERVER/bin && screen -S "CraftalDST" bash -c 'LD_LIBRARY_PATH=~/dst_lib ./dontstarve_dedicated_server_nullrenderer'

 

 

Share this post


Link to post
Share on other sites
G4E    5

(I can't edit my own post ? :x)

And by the way, you shouldn't be logged as root. You should log with the 'dontstarve' user.

Share this post


Link to post
Share on other sites

Issue was that I had not installed libcurl4-gnutls-dev:i386. The first link referred to SteamCMD tutorial. SO I had assumed I had done everything when I completed that. So I forgot to add libcurl. It started now. Also at that run I had indeed forgotten to delete the cd part.

 

All I need to do now for it to work is copy the generated ID file. Thanks for the help :-)

Share this post


Link to post
Share on other sites

Server Succesfully started, but still issues getting it to work.

It does not show up in the list of dedicated servers. Any ideas?

It is being hosted on a dedicated server @ OVH so ports should not be a problem

 

Picture of the server being started up and settings

http://i.snag.gy/BNUAl.jpg

Share this post


Link to post
Share on other sites

I removed the paused when noone online, restarted the server and it worked. Added it again after that and now it works just fine. Thank you for the help everyone. Really appreciated.

 

EDIT: Also wondered if there is a way to only let your steam friends join, like in the normal version. Other than password proecting it.

Share this post


Link to post
Share on other sites
G4E    5

If you add this line in the [network] section of your settings.ini :

friends_only = true

 

 

The server is reported as friends only on the list of servers http://my.jacklul.com/dstservers/

 

I haven't test it in game though. So there is maybe a good reason why this line is not documented on the wiki ;)

 

EDIT :

I tried to play with some friends, it seems to work well.

Share this post


Link to post
Share on other sites