Jump to content

DST downloading problem


Recommended Posts

So when I'm downloading DST from steam everything is fine but after some time my downloading speed drops significantly (from ~850 kb/sec to 1 kb/sec, right know my speed is 300 bytes per sec).

 

Sometimes it goes up to 200 kb/sec and right away drops down.

 

What could be the problem?

Link to comment
Share on other sites

That seems to be because of your own internet speed being distributed to other internet users in your household. Other people on your same internet connection are probably using the internet too. If not, then you are probably also using the internet for streaming videos, etc which would in turn chunk down at your overall internet speed. 

 

If none of these are happening concurrently while you download DST, then I'm sorry I don't have the proper answer for you. 

Link to comment
Share on other sites

That seems to be because of your own internet speed being distributed to other internet users in your household. Other people on your same internet connection are probably using the internet too. If not, then you are probably also using the internet for streaming videos, etc which would in turn chunk down at your overall internet speed. 

 

If none of these are happening concurrently while you download DST, then I'm sorry I don't have the proper answer for you. 

 

No one except me use my internet and only youtube was open. Closesd almost all programs who uses internet but nothing. Checked internet with torrent and everything works fine except steam. 

post-336772-0-40099700-1419172531_thumb.

Link to comment
Share on other sites

No one except me use my internet and only youtube was open. Closesd almost all programs who uses internet but nothing. Checked internet with torrent and everything works fine except steam. 

Sounds like the issue really is on steam's end.Sadly, I wouldn't know how to help any further. But it's good you got a screenshot up. That ETA is terrible. Hopefully someone who knows better can help you out.

 

I do not know if this might work, but have you tried rebooting your router and internet modem? If that doesn't help. I'm sorry. Hopefully it'll work itself out within 24 hours. Good luck.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...