[General] - Can't stop running


Recommended Posts

Bug Submission:

Category: General

Issue Title: Can't stop running

Issue Description: While click-moving, my character will rarely not stop moving in the same direction when I click elsewhere. Pressing WASD will not affect my character, except S (to go backwards) will make me stand in place. Rotating the camera (via keyboard) will make my character change directions. Left-clicking to move and right-clicking (to rotate camera) will do nothing.

I've done this a few times and I think I figured out how to make it happen. I think it triggers whenever I accidently click on the top of the game screen (the bar that lets you move the screen), while my character is moving from a click-move. I've been able to fix it by picking something up, usually.

Not sure if isolated to DST.

Steps to Reproduce: 1. Click to move your character.

2. While character is moving, click and drag the DST game screen.

Link to comment
Share on other sites

  • Developer

Hey @Mysanthil - this sounds like you're giving your character a move command and then taking focus away from the game by clicking elsewhere. I've noticed when alt-tabbing away from the game that it also continues processing whatever my last input was. For me, whenever I click back into the game, it starts behaving normally again. Can you provide some info about the machine you're running on?

Link to comment
Share on other sites

Hmm, I just tried reproducing it and couldn't, so now I'm not so sure what caused it. Alt-tabbing out doesn't do it. I have two monitors and don't need to alt-tab, but being on other screens doesn't cause it.


Not sure what sort of details you're looking for:

Windows 7 Home Premium

Processor: AMD FX-4100 Quad-Core Processor  3.60 GHz



Graphics: AMD Radeon HD 6800


Let me know if you need anything else.



Ok - tried it a few more times and I am getting it to happen maybe 10% of the time when I move (not just by clicking) and then drag the bar. Picking up items didn't fix it this time. Got it again by pressing W+A to move diagonally and clicked the screen's bar. That time I could stop it by clicking in game though.


Sorry, I can't really figure out any consistencies.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.