Jump to content

Mods not working

Recommended Posts

So after about half a year I returned to Don't Starve + RoG and tried some mods. I installed it according to the pinned post in the mod section. When opening the mod-screen ingame, every mod is marked as "Crashed on last start, automatically disabled". Enabling by clicking on a mod works seems to work ("Mod is installed"). But it doesn't. When I return to  he mod-screen all mods are "to be disabled". Starting a game works perfect except it is vanilla.

I tried reinstalling the game and adding mods one by one. Nothing worked and all mods are affected. All but Screecher, it doesn't show any problems.


In case it is important I bought Don't Starve and the DLC from GOG.



Thanks for your help in advance.

Link to comment
Share on other sites

Stupid questions...

Did you unzip the files you downloaded then put them in the "mods" folder in the game directory?

What did you use to unzip the files?

I use Winrar and when I unzip to my desktop, it has a tendency to put the unzipped folder in a DIFFERENT folder of the same name. So I need to change the name of one, yank the folder to my desktop THEN delete the first folder, leaving the unzipped folder with the goods. Once I put that folder in the mods section, I'm good to go.

Also, when I first started downloading mods, I had the same problem as you. The mod would show up in the game mod section but wouldn't work.

Hope this makes sense, let me know what happens.

Link to comment
Share on other sites

I use Winrar too, so that is not the problem.


The path should be fine. It's: C:\GOG Games\Don't Starve\mods\[mod name] and inside the last folder is the respective mod with 2 lua (modinfo, modmain), a tex and a xml file. Along with some folders for the mod.

Link to comment
Share on other sites

I thought it was up to date but to be sure I searched for my build. Without any idea where to look I saw in the console that the API-versions don't match. The game was using 5, the mods 6. After running the updater (which I did before) everything worked without a problem.


Thanks for your help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

  • Create New...