Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

akareggie

Osx, Ps3 Controller, & Joystick Mapper (App)

Recommended Posts

akareggie    0

First of all, thank you guys for finally bringing MotN to Mac! I've been dying to play this game!

Unfortunately, I'm having an issue using my PS3 DualShock controller with the game, while using a controller mapping app called Joystick Mapper for OSX.

I've got custom binds set up through Joystick Mapper so that certain keyboard and mouse clicks can be done through my PS3 controller (i.e. – Square button is bound to Left Mouse Click for attacking, X button is bound to my space bar for jumping, and so on).

However, when trying to play the game, I think the game is trying to read my PS3 controller as a useable controller already, although not accurately. The only thing that works right is the left analog stick, which controls movement just fine. But the D-Pad doesn't work, save for the right D-Pad button, which for some reason pauses the game or goes to the map. Other buttons don't behave right either.
 

And since I have my keys bound to the PS3 controller through my mapping app as well, it's trying to act as two controllers in one.

So... is there a way to make the PS3 controller not recognizable as a buggy gamepad in the game? Maybe an option of some sort? I'd prefer to play with my custom binds on my PS3 controller if possible.

Thanks!

P.S. – I'm running the game on OSX 10.8.4 on my 2011 Macbook Pro, if that info helps at all.

Share this post


Link to post
Share on other sites
oneactlife    0

You can try USB Overdrive, which should work with your dual shock. Create a profile for "ninja" and map the buttons to keys and mouse-presses.

 

This is what I am doing and it works well, though for me it seems like I am always running and cannot disable it. Pressing the run control in my game isn't doing anything. Perhaps you'll have more luck.

Share this post


Link to post
Share on other sites
Tuomas    10

The game has a command line argument "-nocontroller" that disables all joystick or gamepad controllers. Though on OSX you probably then need to start the game through terminal:

/Applications/ninja.app/Contents/MacOS/ninja -nocontroller

(Presuming you have placed ninja.app in Applications folder.)

Share this post


Link to post
Share on other sites
akareggie    0

I think the app I'm using works fine, it's just that the game itself seems like it's trying to input it's own unchangeable bindings into my controller OVER the bindings I made with the Joystick Mapper app (like it thinks my PS3 controller may be the Xbox 360 PC controller, but things aren't matching up). So while I have custom bindings on my PS3 controller through the JM app that work (left, down, and up, for example, all do what they're supposed to do), some buttons still do what the game wants them to do. If that makes sense.

 

I'll try that Terminal line when I get home tomorrow, Tuomas. Yes I have it placed in my Apps folder.

Share this post


Link to post
Share on other sites
GCVigilante    0

Finally got this working just right myself and thought I'd share. No need for terminal commands, you can set launch options by right clicking on the game in the steam window then properties -> launch options -> type "-nocontroller" (no quotes). I used Enjoy2 (http://nongraphical.com/2013/05/enjoy2-v12-released-control-games-with-your-gamepad-on-osx/) to setup key mapping for my PS3 controller but I think Joystick Mapper works too. Here is my mapping file to share (https://db.tt/A5aoZLgE

 

Hope that helps!

Share this post


Link to post
Share on other sites