Jump to content

Mod tools breaking while loading modinfo.lua


Recommended Posts

Posted (edited)

when ever I attempt to open any mod directory into the uploader whether I choose to update an uploaded mod or upload a new mod to the workshop
when I select browse and select folder an error pops up about the compatibility options for modinfo.lua

these are all the files

Spoiler

image.png.f017837bf8c68268cc656d1531cf59c3.png


this info message pops up every time i click the add button in the mod tools

Spoiler

image.thumb.png.00492436a3aa3c789b6e56ce60f62afb.png

this is the error message

Spoiler

image.thumb.png.dea37b9c499896de48c7fa6e38ff8bc9.png


edit: (side note: if i try to upload the mod anyways 2 different errors pop up along the publishing process and the mod page will appear blank without any files preview image, and the mod tools will just display the mod in the menu for updating but all the info is completely blank aswell and the mod is set as hidden)

I've tried to comment out each single line for the compatibility settings
I've tried completely remove all of them
I've tried adding all of them
I've tried upload mods I did not edit since the last time I updated them using the api
I've tried uploading other peoples mods in my mods library
I've tried upload mods from before the workshop installation directory was changed in the api
I've checked with a friend who installed and uploaded one of my mods (I've tried uploading the same mod)
I've ran file validation on the mod tools
I've tried reinstalling the mod tools
I've tried restating my pc
and lastly I've tried manually wiping out the mod tools directory and validating all the files (which reinstalled everything)

if you can help me patch whatever this is I would be most grateful
 

Edited by UltraShadow01
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...