StartDSTServers.bat shuts down


Recommended Posts

Hi! I have encountered some problems while setting up my dedicated server with mods. The thing is that without mods it worked, but now after a while when StartDSTServers.bat is working it just disappears. I have no idea how to work it out, so I will attach the log file. Thanks in advance!

server_log.txt

Link to comment
Share on other sites

5 hours ago, arusstheann said:

Hi! I have encountered some problems while setting up my dedicated server with mods. The thing is that without mods it worked, but now after a while when StartDSTServers.bat is working it just disappears. I have no idea how to work it out, so I will attach the log file. Thanks in advance!

server_log.txt 280.67 kB · 0 downloads

I think I got the wrong log, here are the logs from mydediserver, master and caves.

server_log.txt server_log.txt

Link to comment
Share on other sites

There seems to be a crash happening with the combination of the mods "workshop-1378549454", which seems to be "[API] Gem Core" and "workshop-1079538195", which seems to be "Moving Box".

Spoiler

[00:00:11]: error calling LoadPrefabFile in mod workshop-1079538195 (Moving Box):
[string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)    
[00:00:11]: Disabling workshop-1079538195 (Moving Box) because it had an error.    
[00:00:11]: [string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)
[00:00:11]: [string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)    
[00:00:11]: [workshop-2189004162 (Insight)]:    A crash has occured.    
[00:00:11]: [workshop-2189004162 (Insight)]:    Title:    WARNING!    
[00:00:11]: [workshop-2189004162 (Insight)]:    Text:    [string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)    
[00:00:11]: [workshop-2189004162 (Insight)]:    Additionaltext:    This error may have occurred due to a mod you have enabled!
You have the following mods enabled:
"[API] Gem Core" "Epic Healthbar" "Large Chest" "Show Bundle" "Koalefants Family DST" "Extra Equip Slots" "Steampunk DST" "Automatic chest sorting" "More Armor" "DST Spider Cage" "DST Fish Farm - Terra's Tweaks" "Rabbit Cage" "DST Freezer Enhanced" "Useless Junk" "Increased Stack size" "Wormhole Marks" "Wing Pack" "Stumps grow" "Rope Bridge" "Ralsei" "Potted Plants (DST)" "Ocean Currents" "Not Enough Turfs" "No Extinction" "Moving Box" "More Weapons and Magic" "More Pets <3" "More Gold Tools (DST)" "More Football Helmet & Weapon" "Mass Tree Planting" "Marble tools" "Lightbug Cage" "Item Auto-Fuel Slots" "Invincible Friendly Fruit Fly" "Infinite Tent (and Siesta) Uses " "Heap of Foods" "Fish Bat" "Fireproof Boats" "Eternal Glowcaps & Mushlights" "Cosplay items" "Breakable Ice" "Better Volt Goat Drop" "Beefalo Widget" "Fishing Every Season" "Advanced Drying" "Deluxe Cooking Pot - Fixed!" "Global Positions" "Insight" "Smart Minisign" " Simple Health Bar DST"

It's problably a compatibility issue between them, and disabling either one of them should fix the issue.

Link to comment
Share on other sites

11 hours ago, Daniel86268 said:

There seems to be a crash happening with the combination of the mods "workshop-1378549454", which seems to be "[API] Gem Core" and "workshop-1079538195", which seems to be "Moving Box".

  Reveal hidden contents

[00:00:11]: error calling LoadPrefabFile in mod workshop-1079538195 (Moving Box):
[string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)    
[00:00:11]: Disabling workshop-1079538195 (Moving Box) because it had an error.    
[00:00:11]: [string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)
[00:00:11]: [string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)    
[00:00:11]: [workshop-2189004162 (Insight)]:    A crash has occured.    
[00:00:11]: [workshop-2189004162 (Insight)]:    Title:    WARNING!    
[00:00:11]: [workshop-2189004162 (Insight)]:    Text:    [string "scripts/util.lua"]:619: Could not find an asset matching anim/box.zip in any of the search paths.
LUA ERROR stack traceback:
        =[C] in function 'assert'
        scripts/util.lua(619,1) in function 'resolvefilepath'
        scripts/mainfunctions.lua(118,1) in function 'resolve_fn'
        scripts/mainfunctions.lua(106,1) in function 'RegisterPrefabsImpl'
        scripts/mainfunctions.lua(137,1) in function 'RegisterSinglePrefab'
        scripts/mainfunctions.lua(169,1)
        =(tail call) ?
        =[C] in function 'xpcall'
        scripts/mods.lua(174,1)
        scripts/mods.lua(650,1) in function 'ModMananger_RegisterPrefabs'
        ../mods/workshop-1378549454/gemscripts/memspikefix.lua(145,1) in function 'oldRegisterPrefabs'
    ...
        scripts/saveindex.lua(285,1) in function 'Load'
        scripts/gamelogic.lua(1221,1) in function 'callback'
        scripts/playerprofile.lua(1549,1) in function 'Set'
        scripts/playerprofile.lua(1394,1)
        =[C] in function 'GetPersistentString'
        scripts/playerprofile.lua(1392,1) in function '_Load'
        ../mods/workshop-1378549454/gemscripts/hooks.lua(62,1) in function 'Load'
        scripts/gamelogic.lua(1220,1) in main chunk
        =[C] in function 'require'
        scripts/mainfunctions.lua(1313,1)    
[00:00:11]: [workshop-2189004162 (Insight)]:    Additionaltext:    This error may have occurred due to a mod you have enabled!
You have the following mods enabled:
"[API] Gem Core" "Epic Healthbar" "Large Chest" "Show Bundle" "Koalefants Family DST" "Extra Equip Slots" "Steampunk DST" "Automatic chest sorting" "More Armor" "DST Spider Cage" "DST Fish Farm - Terra's Tweaks" "Rabbit Cage" "DST Freezer Enhanced" "Useless Junk" "Increased Stack size" "Wormhole Marks" "Wing Pack" "Stumps grow" "Rope Bridge" "Ralsei" "Potted Plants (DST)" "Ocean Currents" "Not Enough Turfs" "No Extinction" "Moving Box" "More Weapons and Magic" "More Pets <3" "More Gold Tools (DST)" "More Football Helmet & Weapon" "Mass Tree Planting" "Marble tools" "Lightbug Cage" "Item Auto-Fuel Slots" "Invincible Friendly Fruit Fly" "Infinite Tent (and Siesta) Uses " "Heap of Foods" "Fish Bat" "Fireproof Boats" "Eternal Glowcaps & Mushlights" "Cosplay items" "Breakable Ice" "Better Volt Goat Drop" "Beefalo Widget" "Fishing Every Season" "Advanced Drying" "Deluxe Cooking Pot - Fixed!" "Global Positions" "Insight" "Smart Minisign" " Simple Health Bar DST"

It's problably a compatibility issue between them, and disabling either one of them should fix the issue.

I actually tried redoing setting up the sever  and didn't enable the mods so it works now, I will keep in mind the mods compatibility. Thank you! 

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.