Anyone know why others are seeing "???" for ping and if I can fix it?


Recommended Posts

I recommend you read this topic about how to do port-forward:

In case you need a brief, Klei needs to send packages through your local network so they can show your ping for everybody, but sometimes there is a problem sending the packages, usually for security reasons, like:

  • Problems with your Firewall
  • Closed ports
  • Bad routing process

But the usual problem with the ping is the port-forward, if your problem is this one, follow the next instructions:

  1. Allow the packages go through your router's ports and your server's ports (you can read what ports you need to open on the cluster.ini and server.ini) personally I use the ports 11000, 11001 and 10999 (default ports).
  2. Check your firewall, maybe it's denying the packages.

And that's it, hope it helps you or at least gives you an idea.

Link to comment
Share on other sites

So, my server uses port 11001

So, I have my internet router number one (Huawei)

configured as such

FqPIVrP.png

and then my actual powerful router Tp-Link Archer has it configured as such

mgQtCYt.png

with port forward done as such:

VJYQh8K.png

and my ipconfig is as follows

CTGKbMW.png

and my antivirus bit defender settings look fine

xW1EFLr.png

server is registered in EU lobby

yQkx8aP.png

and still, I can't see the port outside using https://canyouseeme.org/

591rJQR.png

and the browser in-game still shows ??? for ping

iH7Kk0f.png

 

 

5 hours ago, A73 said:

I recommend you read this topic about how to do port-forward:

I have learned a lot about routers and port forwarding reading online, but I don't see what else is missing. I did restart server as well.

Anything looking off?

Link to comment
Share on other sites

yeah, I tried everything

even switched my second router to access point mode, and disabled all my bitdefender antivirus functions, but still no luck

I even forwarded it to my desktop directly

image.png.d45b5be241016aae1da9fffe022280d2.png

Link to comment
Share on other sites

I see you had some troubles making the port-forward, so here are a troubleshooting that I suggest you to try:

  • Check that every device in your local network allows the packages go through (Look the image I uploaded so you can have an idea about what devices may you need to config) I suppose you have 3 devices that connects through your server, every device needs to be configured correctly even your DST-Server, also your routers.
  • Try to open the other ports too, the DST server uses 3 ports to communicate with the WAN network, I recommend you to open all of them so you can see a result (Ports = 11000, 11001, 10999, all the ports in the file cluster.ini and server.ini).
  • If you tried all the previous, I recommend you my last one, just wait; sometimes it takes time to the server to set the ping, so just play on your server, invite a friend, and probably the problem will be solved soon (I say this because sometimes this happens to me too, and I just wait until the server sets by its self).

So, hope this helps you solve your problems and good luck.

dst_network.png

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.