TWO playable servers (one Unraid/Docker server instance)


Recommended Posts

Initially, I though it was a bug where one server was somehow showing-up twice in the game browser, but now it's obvious that there are two separate, playable, servers playable in one Unraid/Docker server instance!

There is only one: /dontstarve directory and only one cluster.ini in the: /token directory.

 

It seems to work fine, but is this normal behavior?  Does the one cluster.ini control both instances (if you change game mode, for example)

Link to comment
Share on other sites

Probably the same as here:

Essentially the same instance just appears twice in the server browser for whatever reason. Connecting to either of them connects you to your server. No idea what causes it though, seems to be a docker related thing.

Link to comment
Share on other sites

8 hours ago, Daniel86268 said:

Probably the same as here:

Essentially the same instance just appears twice in the server browser for whatever reason. Connecting to either of them connects you to your server. No idea what causes it though, seems to be a docker related thing.

No actually!  One server has been played to Day 33 and the other to Day 9!  I made this thread as a follow-up to the other one once I figured-out it wasn't a simply name-replication issue.

They are TWO completely different worlds with different characters!

DST-1a.jpg

DST-2.jpg

Link to comment
Share on other sites

Huh, interesting. If those both are actually from your docker instance, then yes, the cluster.ini controls both servers.

Do you by any chance set both shards to be master_shards, instead of one of them as caves shard? That would mean that instead of one overworld and one cave you have two independant overworld shards. (In the files one of them might still be called caves, but it acts as a overworld shard.)

Link to comment
Share on other sites

7 hours ago, Daniel86268 said:

Huh, interesting. If those both are actually from your docker instance, then yes, the cluster.ini controls both servers.

Do you by any chance set both shards to be master_shards, instead of one of them as caves shard? That would mean that instead of one overworld and one cave you have two independant overworld shards. (In the files one of them might still be called caves, but it acts as a overworld shard.)

Dunno where you would set that, but here's the (edited) cluster.ini   There's no question that they are both my servers since I have to use the same password, etc. to join, and the chance of another server having those credentials is pretty much zero!  ;)

Also, I revised the game mode to endless from survival after re-setting the "Day 8" world by dying and that took effect on both servers as well.

---
[GAMEPLAY]
game_mode = endless
max_players = 6
pvp = false
pause_when_empty = true


[NETWORK]
cluster_description = Dxxxxr Server
cluster_name = Dxxxr
cluster_intention = cooperative
cluster_password = xxxx


[MISC]
console_enabled = true


[SHARD]
shard_enabled = true
bind_ip = 127.0.0.1
master_ip = 127.0.0.1
master_port = 10892
cluster_key = supersecretkey
---

Link to comment
Share on other sites

The interesting stuff in this case would be in the individual server.ini files. There should be two, once for each shard. In there you define which shard is a master server, and which one is a caves server.

Link to comment
Share on other sites

1 hour ago, Daniel86268 said:

The interesting stuff in this case would be in the individual server.ini files. There should be two, once for each shard. In there you define which shard is a master server, and which one is a caves server.

This is from the /Master directory:

---

[NETWORK]
server_port = 10890


[SHARD]
is_master = true


[STEAM]
master_server_port = 27016
authentication_port = 8766


[ACCOUNT]
encode_user_path = true
---

from /Caves

---
[ACCOUNT]
encode_user_path = true
---

Link to comment
Share on other sites

The master one looks good, not sure if the defaults for the caves are enough to launch it as a caves shard. Try using a config like this for the caves:

 [NETWORK]
server_port = 10891


[SHARD]
is_master = false
name = Caves


[STEAM]
master_server_port = 27016
authentication_port = 8767


[ACCOUNT]
encode_user_path = true

This specificially tells the Caves shard to run as a caves shard, that it should run on a seperate port and which the master server port is that it schould connect to.

Also make sure that the worldgenoverride.lua (same directory as the server.ini of the caves shard) contains something like this:

return {
	override_enabled = true,
	worldgen_preset = "DST_CAVE",
	settings_preset = "DST_CAVE",
	overrides = {
	},
}

This makes the caves shard generate a caves world instead of a overworld world.

Afterwards you'll have to regenerate at least the caves shard world.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.