Jump to content

Mods Don't download


Recommended Posts

The dedicated server NEVER attempts to download the mods. It does show that it reads the dedicated_server_mods_setup.lua file.

I have tried different switches when launching the server, I've tried different install locations, I've even tried having just a single mod listed in the dedicated_server_mods_setup.lua file. The server runs perfectly fine, other then it never attempts downloading the mods. It doesn't even list the number of mods like I've seen in other people posted logs.

I'm not sure where to go on this. Am I missing a config option somewhere. Misspelled a file? I even had Steam download all the workshop mods directly.

Added cmd to have SteamCMD download workshop mods

c:\steamcmd\steamcmd.exe +login anonymous +workshop_download_item 322330 1623498822 +workshop_download_item 322330 2225686180 +workshop_download_item 322330 2270316636 +workshop_download_item 322330 2289662010 +workshop_download_item 322330 2311599832 +workshop_download_item 322330 2321974509 +workshop_download_item 322330 2324689937 +workshop_download_item 322330 2420839895 +workshop_download_item 322330 2422129165 +workshop_download_item 322330 2454892046 +workshop_download_item 322330 2456874720 +workshop_download_item 322330 2475231544 +workshop_download_item 322330 2477889104 +workshop_download_item 322330 2487173121 +workshop_download_item 322330 2503293581 +workshop_download_item 322330 2557712505 +workshop_download_item 322330 2584216489 +workshop_download_item 322330 375859599 +workshop_download_item 322330 388109833 +workshop_download_item 322330 1089344410 +quit

My Batch File to launch server. 

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 +quit
cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin64"
start dontstarve_dedicated_server_nullrenderer_x64 -console -cluster Cluster_1 -shard Master
start dontstarve_dedicated_server_nullrenderer_x64 -console -cluster Cluster_1 -shard Caves

 

C:\SteamCMD\steamapps\common\Don't Starve Together Dedicated Server\mods\dedicated_server_mods_setup.lua

ServerModSetup("1623498822")
ServerModSetup("2225686180")
ServerModSetup("2270316636")
ServerModSetup("2289662010")
ServerModSetup("2311599832")
ServerModSetup("2321974509")
ServerModSetup("2324689937")
ServerModSetup("2420839895")
ServerModSetup("2422129165")
ServerModSetup("2454892046")
ServerModSetup("2456874720")
ServerModSetup("2475231544")
ServerModSetup("2477889104")
ServerModSetup("2487173121")
ServerModSetup("2503293581")
ServerModSetup("2557712505")
ServerModSetup("2584216489")
ServerModSetup("375859599")
ServerModSetup("388109833")
ServerModSetup("1089344410")

Running server from batch file

server_log.txt

[00:00:00]: loaded modindex	
[00:00:00]: ModIndex: Beginning normal load sequence for dedicated server.
	
[00:00:00]: SUCCESS: Loaded modoverrides.lua	
[00:00:00]: Event data unavailable: lavaarena_event_server/lavaarena_achievement_quest_defs
[00:00:02]: LOADING LUA SUCCESS

 

Running server with -only_update_server_mods switch

server_log.txt

[00:00:00]: running main.lua
	
[00:00:00]: loaded modindex	
[00:00:00]: ModIndex: Beginning normal load sequence for dedicated server.
	
[00:00:00]: FinishDownloadingServerMods Complete!

 

C:\Users\ark.admin\OneDrive\Documents\Klei\DoNotStarveTogether\Cluster_1\Master\modoverrides.lua

return {
  ["workshop-1089344410"]={ configuration_options={ GOLDENTOOLFACTOR=4 }, enabled=true },
  ["workshop-1623498822"]={
    configuration_options={
      ENABLEPINGS=true,
      FIREOPTIONS=1,
      OVERRIDEMODE=false,
      SHAREMINIMAPPROGRESS=true,
      SHOWFIREICONS=true,
      SHOWPLAYERICONS=true,
      SHOWPLAYERSOPTIONS=3 
    },
    enabled=true 
  },
  ["workshop-2225686180"]={ configuration_options={  }, enabled=true },
  ["workshop-2270316636"]={
    configuration_options={
      CENTERWHEEL=true,
      EIGHT1="wave",
      EIGHT2="dance",
      EIGHT3="happy",
      EIGHT4="bonesaw",
      EIGHT5="rude",
      EIGHT6="facepalm",
      EIGHT7="sad",
      EIGHT8="kiss",
      IMAGETEXT=3,
      KEYBOARDTOGGLEKEY="G",
      ONLYEIGHT=false,
      RESTORECURSOR=3,
      RIGHTSTICK=false,
      SCALEFACTOR=1 
    },
    enabled=true 
  },
  ["workshop-2289662010"]={
    configuration_options={
      RAILCART_BRAKING=1,
      RAILCART_CRAFTAMOUNT=6,
      RAILCART_DAMPING=1,
      RAILCART_FIREPROOF=false,
      RAILCART_PLAYSOUND=true,
      RAILCART_SPAWNSMOKE=true,
      RAILCART_SPEEDUP=1 
    },
    enabled=true 
  },
  ["workshop-2311599832"]={ configuration_options={ needprint=false }, enabled=true },
  ["workshop-2324689937"]={
    configuration_options={
      config_render=true,
      slot_amulet="extrabody3",
      slot_armor=false,
      slot_backpack=false,
      slot_band=false,
      slot_clothing="extrabody2",
      slot_heavy=false,
      slot_lifevest=false,
      slot_shell=false 
    },
    enabled=true 
  },
  ["workshop-2420839895"]={
    configuration_options={
      ROPE_BRIDGE_BOARDS_RATIO=0.375,
      ROPE_BRIDGE_DISTANCE=16,
      ROPE_BRIDGE_ROPE_RATIO=0.375 
    },
    enabled=true 
  },
  ["workshop-2422129165"]={
    configuration_options={
      deluxeEndoFirepitBurnRate=0.75,
      deluxeFirepitBurnRate=0.75,
      dropLoot="yes",
      endoDropLoot="yes",
      heatStarBurnRate=0.75,
      heatStarDropLoot="yes",
      iceStarBurnRate=0.75,
      iceStarDropLoot="yes",
      recipeCost="standard",
      starsSpawnHounds="no" 
    },
    enabled=true 
  },
  ["workshop-2454892046"]={
    configuration_options={
      [""]=0,
      enable_ui_fix=true,
      large_stack_size=10,
      medium_stack_size=20,
      small_stack_size=40 
    },
    enabled=true 
  },
  ["workshop-2456874720"]={
    configuration_options={
      hammer=false,
      hammer_consumption=1.25,
      hammer_craft=true,
      hammer_hammering=2.5,
      hammer_mining=2.5,
      pitchfork=false,
      pitchfork_consumption=1.25,
      pitchfork_craft=true,
      pitchfork_range=1,
      shovel=false,
      shovel_consumption=1.25,
      shovel_craft=true,
      shovel_range=6 
    },
    enabled=true 
  },
  ["workshop-2475231544"]={ configuration_options={ VACUUM_BAG_RADIUS=10 }, enabled=true },
  ["workshop-2477889104"]={
    configuration_options={
      BADGE_BG_BRIGHTNESS=60,
      BADGE_BG_OPACITY=100,
      COLOR_DOMESTICATION_DEFAULT="WHITE",
      COLOR_DOMESTICATION_ORNERY="ORANGE",
      COLOR_DOMESTICATION_PUDGY="PURPLE",
      COLOR_DOMESTICATION_RIDER="BLUE",
      COLOR_OBEDIENCE="RED",
      COLOR_TIMER="GREEN",
      ClientConfig=false,
      EnableSounds=false,
      GapModifier=0,
      HEALTH_BADGE_CLEAR_BG=false,
      HungerThreshold=10,
      OffsetX=0,
      OffsetXFine=0,
      OffsetXMult=1,
      OffsetY=0,
      OffsetYFine=0,
      OffsetYMult=1,
      SEPARATOR_BADGE_COLORS=1,
      SEPARATOR_BADGE_SETTINGS=1,
      SEPARATOR_GENERAL=1,
      SEPARATOR_POSITIONING_X=1,
      SEPARATOR_POSITIONING_Y=1,
      Scale=1,
      ShowByDefault=true,
      Theme="TheForge",
      ToggleKey="KEY_T" 
    },
    enabled=true 
  },
  ["workshop-2487173121"]={
    configuration_options={
      key_kodi=120,
      kodidamageblock=0.1,
      kodidamagemult=0.95,
      kodihp=150,
      kodihunger=125,
      kodilanguage="ENGLISH",
      kodisanity=125 
    },
    enabled=true 
  },
  ["workshop-2503293581"]={ configuration_options={  }, enabled=true },
  ["workshop-2557712505"]={
    configuration_options={
      Craft="Normal",
      Destroyable="DestroyByAll",
      Language="En",
      Position="Center",
      Slots=80 
    },
    enabled=true 
  },
  ["workshop-2584216489"]={ configuration_options={  }, enabled=true },
  ["workshop-375859599"]={
    configuration_options={
      divider=5,
      random_health_value=0,
      random_range=0,
      send_unknwon_prefabs=false,
      show_type=0,
      unknwon_prefabs=1,
      use_blacklist=true 
    },
    enabled=true 
  },
  ["workshop-388109833"]={ configuration_options={  }, enabled=true } 
}

 

Server Reads Mods Setup file.png

Link to comment
Share on other sites

I figured out my problem. x64 bit doesn't support the mods.

Ran in 32bit mode to fix

 

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 +quit
cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
start dontstarve_dedicated_server_nullrenderer -console -cluster Cluster_1 -shard Master
start dontstarve_dedicated_server_nullrenderer -console -cluster Cluster_1 -shard Caves
Link to comment
Share on other sites

The download part seems like it was just skipped in the logs. It didn't download the mods until after switching to the 32bit executable.

Perhaps, the workaround is to run as 32bit for it to download the mods, then switch to 64bit after. I will have to test this as some point.

Link to comment
Share on other sites

I guess for the time being you could do something like this as a startup script:

c:\steamcmd\steamcmd.exe +login anonymous +app_update 343050 +quit

cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin"
.\dontstarve_dedicated_server_nullrenderer -console -only_update_server_mods

cd /D "c:\steamcmd\steamapps\common\Don't Starve Together Dedicated Server\bin64"
start dontstarve_dedicated_server_nullrenderer_x64 -console -cluster Cluster_1 -shard Master
start dontstarve_dedicated_server_nullrenderer_x64 -console -cluster Cluster_1 -shard Caves

This should update the mods using the 32bit server, and then, once it's done, it'll start the 64bit Server.

Might need some tweaking or adjustments, since I just patched this code together real quick and it could contain errors.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
  • Create New...