Jump to content

Item textures invisible, not sure what to do

Recommended Posts

I've been posting on here for the past 2 days trying to figure out what my problem is and I still can't, but I think I may have an idea.

After following the Extended Sample Character Template tutorial, I got far making my character, until I wanted to add my own custom item, which is just an upgraded Tentacle Spike. I started off just using the texture of a tentacle spike and I got the item fully functional, but as soon as I switched to a custom texture I couldn't get it to show up at all in my hand. It looked like this.

The red umbrella item is the problem item, and I have NO IDEA where to even try to find out what's wrong. The debug menu shows something weird, that the item is tagged as INLIMBO, which I can tell you I didn't set in the script. Any help here would be appreciated.

Full mod download link, and problem texture link is below.

The problem item is hatbrella2.

Full Mod.zip swap_hatbrella2.zip

Link to comment
Share on other sites

5 hours ago, IronHunter said:

It looks like you are trying to call a symbol from the wrong build for hatbrella2 as your lua file says you are calling from the hatbrella2.zip but you probably want to call from swap_hatbrella2.zip instead

I tried that, no effect. I'm beginning to think something is wrong with the texture itself. I tried replacing it with a different texture and got it to load correctly.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...