Jump to content

Host Game - Server stuck at Launching Server


Recommended Posts

Hi Klei team, I was playing my 400+ days server with friends, when 3 of them pop by. It was summer and some things caught fire, and i tried to backup the cluster files and tried to overwrite and restore back.(copy and paste from my doc, whole DST folder)

After which i am stuck at Launching server prompt and it never loads. As believed there is a looping in caves shard, but i am not sure how to fix it. I have uploaded both Master server log and Cave server logs.

Please help to save me 400days and 100 hrs of gameplay >.<

Mserver_log.txt Cserver_log.txt

Link to comment
Share on other sites

I can't really tell, what the exact cause for this issue is, but I have two ideas what it could be:

1. Sometimes, when the Caves shard starts up before the Master/Overworld one does, it can't connect properly. Try starting the Master shard completely before starting the Caves shard.

2. You do have quite a few mods running, maybe there's some sort of conflict going on. Try launching the server without mods (after making sure your entire world is backed up somewhere, cause this will delete items and structures such as the storeroom) and see if in launches.

 

Additional note: In the future you can just roll back to a previous point using the command: "c_rollback()", which rolls back to the last save, or "c_rollback(n)" where n is the number of days you want to roll back. No need to touch the files.

Link to comment
Share on other sites

Seems like my Master is running session 495/6,

[00:00:05]: Loading world: session/2D7C675BA0C416E6/0000000495    
"[00:01:47]: Serializing world: session/2D7C675BA0C416E6/0000000496"

But my caves dont have session 496?

[00:01:24]: Restoring user: session/6BE12A6CF8BAE662/A7LPQIFIR2HN/0000000497    
[00:01:24]: Restoring user: session/6BE12A6CF8BAE662/A7I62TKU23RV/0000000497    
[00:01:24]: Restoring user: session/6BE12A6CF8BAE662/A7I62TKU20JC/0000000497    
[00:01:24]: Serializing user: session/6BE12A6CF8BAE662/A7I62TKU20JC/0000000498
[00:01:24]: Serializing user: session/6BE12A6CF8BAE662/A7I62TKU23RV/0000000498
[00:01:24]: Serializing user: session/6BE12A6CF8BAE662/A7LPQIFIR2HN/0000000498
[00:01:24]: 1 uploads added to server. From server_temp
[00:01:24]: World 1 is now connected    
[00:01:24]: Telling Client our new session identifier: 6BE12A6CF8BAE662
[00:01:24]: Check for write access: TRUE
[00:01:24]: Check for read access: TRUE
[00:01:24]: ModIndex: Load sequence finished successfully.    
[00:01:24]: Reset() returning
[00:01:24]: Synchronizing backward to master snapshot 495    
[00:01:24]: Truncating to snapshot #497...
[00:01:24]:  - session/6BE12A6CF8BAE662/A7I62TKU20JC/0000000498
[00:01:24]:  - session/6BE12A6CF8BAE662/A7I62TKU23RV/0000000498
[00:01:24]:  - session/6BE12A6CF8BAE662/A7LPQIFIR2HN/0000000498
[00:01:24]:    3 file(s) removed
[00:01:25]: Collecting garbage...
[00:01:25]: lua_gc took 0.14 seconds
[00:01:25]: ~ShardLuaProxy()
[00:01:25]: ~cEventLeaderboardProxy()
[00:01:25]: ~ItemServerLuaProxy()
[00:01:25]: ~InventoryLuaProxy()
[00:01:25]: ~NetworkLuaProxy()
[00:01:25]: ~SimLuaProxy()
[00:01:25]: lua_close took 0.30 seconds
[00:01:25]: ReleaseAll
[00:01:25]: ReleaseAll Finished
[00:01:25]: cGame::StartPlaying
[00:01:25]: LOADING LUA

~~~~

and this loops in caves file.

13 hours ago, Daniel86268 said:

I can't really tell, what the exact cause for this issue is, but I have two ideas what it could be:

1. Sometimes, when the Caves shard starts up before the Master/Overworld one does, it can't connect properly. Try starting the Master shard completely before starting the Caves shard.

2. You do have quite a few mods running, maybe there's some sort of conflict going on. Try launching the server without mods (after making sure your entire world is backed up somewhere, cause this will delete items and structures such as the storeroom) and see if in launches.

 

Additional note: In the future you can just roll back to a previous point using the command: "c_rollback()", which rolls back to the last save, or "c_rollback(n)" where n is the number of days you want to roll back. No need to touch the files.

1. I may have posted in the wrong place, as mine is DST multiplayer online HOST mode only, not dedicated server, but i saw similar issues with loading screen issue. Not sure how to start master without starting shards.

2. I have tried without mods same issues. the game just stuck at loading prompt

yeah, usually i rollback with the gui, first time i did this mistake..

Link to comment
Share on other sites

OMG I HAVE RESOLVED MY ISSUE!!!!

Server started, and i lost my character, became a Day 1 character, but the world and items in the world is all around, and belonging is still around, Effectively i only lost the items on my character..

As per my previous post, i deduce the caves was trying to load into the session same file as the master, and went into a infinite loop.

I Had quite a few files , i assume this are the save games.

session/6BE12A6CF8BAE662/A7I62TKU20JC/0000000497    
session/6BE12A6CF8BAE662/A7I62TKU20JC/0000000498
session/6BE12A6CF8BAE662/0000000498
session/6BE12A6CF8BAE662/0000000497
session/6BE12A6CF8BAE662/0000000492

in both the Master Session and Caves session, i deleted all of them and kept 1 copy each in their respective folder "session/6BE12A6CF8BAE662/0000000492" be careful not to use the caves for the master, i am not sure if they are different and if it affects anything.
 

and it managed to load..!! 
so cave shard was trying to roll back to 496, and it didnt want 498 and 497. (but there is no session files for 496 for caves)

While server shard was running 495 and 496.
once i deleted all the files and only kept 492, game server started fine....

now, if any mod/dev and answer this:
1. If i change the numbers, does it affect the loading of the game? meaning i change the session file from 495-> 492 will it work? or will it give issues/not recommended?
2. How do i locate back my character information in all these files? why does the game save session unable to find my character? (it shows ? and asked me to select a character to join the game) after the server started

So i can explore more and see if i can fix this last thing.
 

Link to comment
Share on other sites

Resolved!

1. I found i need to look for the session file inside the folder:

session\6BE12A6CF8BAE662\A7LPQIFIQSBB\0000000492 - that is my character, in both caves and master.

 

can mark as closed.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

Please be aware that the content of this thread may be outdated and no longer applicable.

×
×
  • Create New...