Jump to content

Hat disappears when dropped

Recommended Posts

Okay. I've searched and searched and yes, I have found numerous threads with the same/similar problem, and yet the solution continues to evade me. orz

I decompiled the flowerhat, adjusted the colors of the resulting .png files, renamed the .scml to my own prefab, and recompiled everything. It works fine until I drop the hat on the ground and then it turns invisible. Can someone please take a look at my anim folder and .lua and hopefully tell me what I'm doing wrong?




bumble hat.zip

Edited by Birdskull
pressed enter too soon
Link to comment
Share on other sites

2 hours ago, Ultroman said:

I think you just need to change this:


to this:



Alas, I've tried that, and did again just now for good measure... No dice. :c

Link to comment
Share on other sites

Well, that's unfortunate.

I think I've fixed it. I went to your SCML's and changed the entity name to "happy_bees" instead of "flowerhat", and changed the corresponting line in the prefab. I also changed PlayAnimation("anim") to PlayAnimation("anim90s"), since the animation in your SCML's seems to be called that for some reason.

Delete your current zip files in the anim folder, and make new builds with the files in the "exports" folder I've sent, and replace your prefab file as well.

bumble hat.zip

Link to comment
Share on other sites

YES! That did it! Thank you!!

It didn't show with "anim90s" in the lua but when I changed that back to idle the dang hat finally showed on the ground. I've never been so happy to see a pixel flower crown. Thank you so much.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...