thenat97

Cannot override disease values using console

Recommended Posts

thenat97    0

Hello everybody, i need some help with my dst world, i forgot to turn off disease and it is driving me crazy, i searched in the internet ways to turn it off, i found using console commands is the way to go, but when i use them nothing changes, here is the console command i am using to change this: TheWorld.topology.overrides.disease_delay = "none"

Any help is apreciated, thanks

Share this post


Link to post
Share on other sites
Daniel86268    272
6 hours ago, thenat97 said:

TheWorld.topology.overrides.disease_delay = "none"

The command is correct. Just make sure that you are running the command as admin, and, in case it's a dedicated server, with the infamous "Remote: " in front of the command line.

(The "Remote: " is toggled by pressing <ctrl>, and therefore get's toggled when pasting something into the command console using <ctrl>+v.)

Afterwards restart your server for the change to take effect.

Also keep in mind that you have to change it for every shard. Means if you are running a Forest+Caves world, you have to execute it once on the forest shard, and once on the caves shard for both to be changed.

Share this post


Link to post
Share on other sites
thenat97    0

How do i know i am running as an admin? i am the one running the server, and i do make sure that a i am using the remote in the console command line, and funny enough i just forgot to turn disease of in the overworld, caves are fine.

Share this post


Link to post
Share on other sites
Daniel86268    272

As long as the key you are running your server on is generated by your account, you are automaticially admin on the server.

Keep in mind, this doesn't remove any existing disease from the map, and already replanted plants might still disease until replanted. Only after replanting once again they'll be safe.

Share this post


Link to post
Share on other sites
thenat97    0

Ok, is there a way to know that the disease has gone completely of the server? I dont have diseased plants in this moment but i want to make sure that in the future there will not be disease

 

Share this post


Link to post
Share on other sites
Daniel86268    272

The easiest way would be to check for a line like this in your server log:

[00:00:32]: OVERRIDE: setting	disease_delay	to	none

(This means it worked)

Share this post


Link to post
Share on other sites
thenat97    0

Ok, so i entered the command and checked the console log of my server, this are the things i found, either way, i dont see any override confirmation, any thoughts?

comandos.PNG

not aplying.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now