TechiMAn

Help with Dedicated set up -encountering errors

Recommended Posts

TechiMAn    0

Hey guys I have been trying to get a dedicated server up and running and I can get it to run and my friends can connect but I cant seem to get it to change any settings so I think I have the cluster.ini etc in the wrong folder, right now they are in Documents\Klei\DoNotStarveTogetherDedicated\Cluster_1\Master

but it looks like the server is looking for them back one dir, in cluster_1 but if I move them there there is no change... 

can someone have a look at this log and settings and get me on the right path so I can set start worrying about configuring the world how I want... 

right now if you see the game hosted it shows up as [Host]'s World... 

 

I have read the wiki and the forums and have tried alot of the settings in the cluster.ini and I have tried them in server.ini and neither seems to make a difference.

 

TIA!

 

 

server.ini

cluster.ini

server_log.txt

Edited by TechiMAn

Share this post


Link to post
Share on other sites
Daniel86268    264
13 hours ago, TechiMAn said:

I think I have the cluster.ini etc in the wrong folder, right now they are in Documents\Klei\DoNotStarveTogetherDedicated\Cluster_1\Master

You are correct, the cluster.ini belongs into "Documents\Klei\DoNotStarveTogetherDedicated\Cluster_1".

The server.ini belongs into the Master and Caves folders.

 

Additional note:

The [shard] settings don't belong into the cluster file, since the cluster.ini controls the individual shard settings, such as defining which one is the master. The files should be configured as follows, and edited according to your own needs:

server.ini

Spoiler

[NETWORK]
server_port = 11000


[SHARD]
is_master = true


[STEAM]
master_server_port = 27018
authentication_port = 8768

cluster.ini

Spoiler

[GAMEPLAY]
game_mode = survival
max_players = 6
pvp = false
pause_when_empty = true


[NETWORK]
cluster_description = This server is super duper!
cluster_name = Super Server
cluster_intention = cooperative
cluster_password =


[MISC]
console_enabled = true


[SHARD]
shard_enabled = true
bind_ip = 127.0.0.1
master_ip = 127.0.0.1
master_port = 10889
cluster_key = supersecretkey

(Default files taken from here)

Edited by Daniel86268
  • Thanks 1

Share this post


Link to post
Share on other sites
TechiMAn    0

OK I was able to get it sort of working, the caves server does not seem to auth to the master,,,

Quote

[00:02:55]: About to start a shard with these settings:
[00:02:55]:   ShardName: Caves
[00:02:55]:   ShardID: 1638032267
[00:02:55]:   ShardRole: SLAVE
[00:02:55]:   MasterHost: 127.0.0.1
[00:02:55]:   MasterBind: (null)
[00:02:55]:   MasterPort: 10999
[00:02:55]: [Shard] Connecting to master...
[00:03:05]: [Shard] Connection to master failed. Waiting to reconnect...

the port is correct....

 

I can not get either of these commands to work no mater what I do, the server log shows it as false and it shows in the server log as false... I tried putting it in the server.ini and in the cluster.ini

pause_when_empty = true
PauseWhenEmpty = true

 

Also not working is the game mode is being ignored as well, I cant seem to get it into endless.

 

 

TIA.

 

 

cluster.ini

server_log.txt

Edited by TechiMAn

Share this post


Link to post
Share on other sites
Daniel86268    264

Well, you know, five times true equals false :rolleyes:

GAMEPLAY]
[...]
PauseWhenEmpty = true
pause_when_empty = true


[NETWORK]
[..]
pause_when_empty = true
PauseWhenEmpty = true
pause_when_empty = true

all jokes aside, try to avoid dumping various versions of the same variable in the config files, it might mess things up.

Considering that the log says:

[00:00:04]:   Intent: endless

I assume that setting worked, and the cluster.ini by itself got loaded.

Try running the server with just the

pause_when_empty = true

setting under [GAMEPLAY].

Five of them might've confuse the server, or it didn't load the one you actually needed because you missed the first [ at [GAMEPLAY].

  • Like 1

Share this post


Link to post
Share on other sites
TechiMAn    0

well the 5 x was out of frustration initially it was just once in the cluster.ini

then I started trying things..

 

I have put it back to just one under gameplay, but it still does not work.

 

the game is def in survival mode and it seems to be ignoring some settings.

 

 

Edited by TechiMAn

Share this post


Link to post
Share on other sites
Daniel86268    264

Did you also add

3 hours ago, Daniel86268 said:

the first [ at [GAMEPLAY].

?

cause you missed that one as well.

  • Thanks 1

Share this post


Link to post
Share on other sites
TechiMAn    0

that [ was the problem %100 I feel like an ID10T!!! thank you, Now I just need to get the caves shard talking to the master.... but at least we can get started.

 

Share this post


Link to post
Share on other sites
Daniel86268    264
13 hours ago, TechiMAn said:

that [ was the problem %100 I feel like an ID10T!!! thank you,

You are welcome :D

13 hours ago, TechiMAn said:

Now I just need to get the caves shard talking to the master.... but at least we can get started.

The server should automaticially connect the Master and Cave shards, once they are both configured correctly and running at the same time.

Share this post


Link to post
Share on other sites
TechiMAn    0
On 2019-01-30 at 9:47 AM, Daniel86268 said:

You are welcome :D

The server should automaticially connect the Master and Cave shards, once they are both configured correctly and running at the same time.

I beleive that this Error in the log is the clue as to why its not working.

[Error] Attempting to use the same port number (10999) for master_port and server_port
[00:00:22]: [Shard] Stopping shard mode

 

this is the caves server.ini

[ACCOUNT]
encode_user_path = true


[NETWORK]
server_port = 11000


[SHARD]
is_master = false
name = Caves
id = 1638032267
cluster_key = xxxxxx


[STEAM]
master_server_port = 27019
authentication_port = 8769
 

Share this post


Link to post
Share on other sites
Daniel86268    264
1 hour ago, TechiMAn said:

[Error] Attempting to use the same port number (10999) for master_port and server_port

Try changing up the server_port on the master or the caves server (or both), as it seems that either they are both trying to run on the same port, or a port that is occupied. Even though it says 11000, I heard it has issues with some ports, so just change them up a little and see if that works.

Share this post


Link to post
Share on other sites
TechiMAn    0

ok from what I have figured out is you need 3 ports for it to work

Master

Server 1 Overworld

server 2 Caves

once I added the 3rd port in the mix it worked so in the 

cluster I set the master 10997

 

Then in the master folder I set server ini port to 10998

in the caves folder server ini port to 10999

 

then it worked like a charm.

No I just need to remember to update the firewall rules and I will be all set..

Share this post


Link to post
Share on other sites
Daniel86268    264
19 hours ago, TechiMAn said:

set the master 10997

 

Then in the master folder I set server ini port to 10998

in the caves folder server ini port to 10999

Correct.

The master port defined in the cluster.ini is the port where the master and slave shards communicate over, and the other two are the individual ports where the players connect to the shards over.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now