Jump to content

My mod won't compile.

Recommended Posts

Hello, I'm working on a character mod using extended sample character, but for some reason, the autocompiler in Don't Starve Mod Tools doesn't work at all. No text, nothing. It opens before I launch the game to be blank, and then after a few moments, it closes. It does the same when I launch it myself. I'm new to modding, but I've scoured the internet for pretty much everything I could think of to see if I did something wrong. I've reinstalled Mod Tools 4 times, ran it as admin, but nothing. As a test, I emptied my mods folder, placed in esctemplate with a few compiled files removed, and ran the compiler. It still didn't do anything. I even tried running scml and png.exe, but to no avail, since they immediately close.
I'm at a loss here. I really enjoy this game and have worked pretty hard on this mod, and also spent a lot of time trying to figure out the problem, so I've pretty much exhausted all of my options except for to post on these forums. 

image.png.90681152d7d0741064ec2a85ca093a74.png black like this for about 20 secs

Any sort of help would be appreciated!

Link to comment
Share on other sites

That is a very tiny command-prompt you have there. If it's always like that, open a cmd, go to the upper-left corner, and right-click on the icon. Select "Defaults". Go to the "Layout" tab, and set it to this:


With regards to the png.exe and scml.exe, they are command-line programs, which usually means you need to run them from the command-prompt or through a batch-file or through a program (like the modtools) to give them parameters, otherwise they don't know what to do. You can't just double-click them.

What exactly are you trying to accomplish? Does the mod not work? Are you trying to upload it to the store?

Edited by Ultroman
Link to comment
Share on other sites

I have tried resizing the window, but just no words seem to appear in the compiler. I'm trying to run it to export the files I'm working on, but nothing seems to actually work. What's weirder is that I've just tried to run cmd.exe, to which is flashes and closes with the same thing.
Is this windows 8? Apparently there's nothing wrong with my mod itself. I put my files on a drive and ran the autocompiler on another computer that's windows 10, which it ran just fine.

Link to comment
Share on other sites

I think you need to consider that you might have a virus, m8. Running cmd.exe should give you the command prompt. Please do a search with your favorite and perhaps also second favorite anti-virus software, and then do one with Malwarebytes Anti-malware.

If none of that raises alarms, there should be others who've had the same problem. You need cmd.exe to work, for SO MANY reasons.

Edited by Ultroman
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...