Jump to content

Inconsistent liquid delivery by Auto-Sweepers


vladimmi
  • Branch: Live Branch Version: Windows Pending

I have a very confusing (for me) bug - new-built auto-sweepers for some reason ignore delivery of liquids from pitcher pumps to bottle emptiers. Element filter on emptier is set, auto-bottle enabled, liquid is available. When dupes are allowed to walk there, they manually deliver bottles, but sweeper just stays inactive even when dupes are not allowed. At the same time the same sweeper delivers solids (like debris to loader) just as usual. This was seen both in main game save (with mods and stuff) and sandbox game with all mods disabled - it does not deliver even simple water.

What is confusing, though, is that old sweepers in the main save, built some time ago, still work and deliver liquid metals from pumps to emptiers just like they did before. But new built sweeper in the same game just ignores liquids.


Steps to Reproduce
  • build a pitcher pump with some liquid
  • build a bottle emptier near it
  • select corresponding liquid in emptier's settings
  • enable auto-bottle
  • build an auto-sweeper that can reach both of them
  • ...
  • nothing happens



User Feedback


Quote

What is confusing, though, is that old sweepers in the main save, built some time ago, still work and deliver liquid metals from pumps to emptiers just like they did before. But new built sweeper in the same game just ignores liquids.

Auto-sweepers delivering liquids is a mod. On an unmodded game, auto-sweepers can't do that. Are you sure you didn't use a mod on your previous save? Or maybe the mod you were using broke after an update?

Share this comment


Link to comment
Share on other sites

2 hours ago, sakura_sk said:

Auto-sweepers delivering liquids is a mod. On an unmodded game, auto-sweepers can't do that.

No, it's not. After your words I've went to search again and found another hint to retest. So...

Sandbox, all mods off. Auto-sweepers ARE actually delivering liquid metals from pitcher pump to bottle emptier. Why do metal liquids have special treatment from them? Maybe sweepers should either deliver all liquids or no liquids at all?

I've updated topic title to reflect the changes. After all, it feels wrong when you have two pitcher pumps, two bottle emptiers and from all the list of liquids it works just with specific ones. Some consistent behavior would be great, I believe.

Edited by vladimmi
Updates

Share this comment


Link to comment
Share on other sites

9 hours ago, vladimmi said:

Auto-sweepers ARE actually delivering liquid metals from pitcher pump to bottle emptier.

Is there some specific build where sweepers can do that? I still can't see the sweeper delivering anything

image.thumb.png.e0c300d31c7a66c429fb16c421c1335c.png

(I also put copper and iron before making the puddle steel)

Share this comment


Link to comment
Share on other sites

No, nothing special, it should work just like you did. Do you have auto-bottle enabled on emptier? In my game it works with liquid gold and aluminum, some tricky volcano tamer tutorials use it for niobium, etc.

Share this comment


Link to comment
Share on other sites

So far I've found several mentions of sweepers being "metal-only" but never seen any info on why is that. So no idea whether this behavior is intended for some reasons or just a bug/side-effect of metals still being treated as metals no matter solid or liquid.

Share this comment


Link to comment
Share on other sites



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...