100% Crash Rate on Game Launch


RCNBob
  • Branch: Live Branch Version: Windows Pending

I see there are other posts of this type, but they all seem to reference OSX. I'm running Win 10 64x Home.

Game has been uninstall, reinstalled, file integrity check, all old saves/settings deleted, and all mods removed. The only thing that gets my past the 'klei' screen is uninstalling spaced out. No log file appears to be generated.

 

Error in MainMenu_SpacedOut(Clone).MainMenu.OnPrefabInit 
System.NullReferenceException: Object reference not set to an instance of an object
  at SaveLoader.GetLatestSaveForCurrentDLC () [0x0001a] in C:\jenkins_workspace\workspace\SimGame_Windows\game\Assets\scripts\game\SaveLoader.cs:765 
  at MainMenu.RefreshResumeButton () [0x00001] in C:\jenkins_workspace\workspace\SimGame_Windows\game\Assets\scripts\ui\MainMenu.cs:521 
  at MainMenu.OnPrefabInit () [0x00134] in C:\jenkins_workspace\workspace\SimGame_Windows\game\Assets\scripts\ui\MainMenu.cs:125 
  at KMonoBehaviour.InitializeComponent () [0x0007f] in C:\jenkins_workspace\workspace\SimGame_Windows\game\Assets\Plugins\Klei\util\KMonoBehaviour.cs:132 

UnityEngine.Debug:LogError(Object, Object)
Debug:LogError(Object, Object) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Debug.cs:152)
DebugUtil:LogErrorArgs(Object, Object[]) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/DebugUtil.cs:191)
DebugUtil:LogException(Object, String, Exception) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/DebugUtil.cs:201)
KMonoBehaviour:InitializeComponent() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/KMonoBehaviour.cs:138)
KMonoBehaviour:Awake() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/KMonoBehaviour.cs:44)
UnityEngine.Object:Instantiate(GameObject, Transform, Boolean)
Util:KInstantiateUI(GameObject, GameObject, Boolean) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/Util.cs:280)
FrontEndManager:OnPrefabInit() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/scripts/ui/FrontEndManager.cs:31)
KMonoBehaviour:InitializeComponent() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/KMonoBehaviour.cs:132)
KMonoBehaviour:Awake() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/KMonoBehaviour.cs:44)
UnityEngine.Object:Instantiate(GameObject, Vector3, Quaternion)
Util:KInstantiate(GameObject, Vector3, Quaternion, GameObject, String, Boolean, Int32) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/Util.cs:215)
SceneInitializer:PreLoadPrefabs() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/scripts/game/SceneInitializer.cs:52)
SceneInitializer:Awake() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/scripts/game/SceneInitializer.cs:35)
UnityEngine.Object:Instantiate(GameObject, Vector3, Quaternion, Transform)
Util:KInstantiate(GameObject, Vector3, Quaternion, GameObject, String, Boolean, Int32) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/Util.cs:226)
Util:KInstantiate(Component, GameObject, String) (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/Plugins/Klei/util/Util.cs:193)
SceneInitializerLoader:Awake() (at C:/jenkins_workspace/workspace/SimGame_Windows/game/Assets/scripts/game/SceneInitializerLoader.cs:27)
 


Steps to Reproduce

DxDiag.txt



User Feedback


....

As an additional note, I have tried the game on two separate computers now (A desktop and a laptop, both Win 10 64x) with the same result.

Share this comment


Link to comment
Share on other sites
....

Hi @RCNBob! Thanks for the report! I'm looking into this right now. The crash you've posted in this message is helpful and I think I've found the problem, but if you're able to post your Player.log here as well, that would help me confirm that I've solved the correct issue. Thanks!

Share this comment


Link to comment
Share on other sites
....
13 minutes ago, Ipsquiggle said:

Hi @RCNBob! Thanks for the report! I'm looking into this right now. The crash you've posted in this message is helpful and I think I've found the problem, but if you're able to post your Player.log here as well, that would help me confirm that I've solved the correct issue. Thanks!

Thanks for the prompt reply! Hope this is the right file.

Player.log

Share this comment


Link to comment
Share on other sites
....

Awesome, that was the correct file and very helpful, thanks!

I'm putting in a fix so that this won't crash anymore.

However, would you be able to post your newest save file (note: it may be an autosave)? It seems like there's something about that file that's triggering the issue, and I'd like to make sure there isn't a deeper problem.

In any case, once the next patch goes live, this crash will go away. You can also work around it in the meantime by moving your newest save file out of the saves folder as it seems to be causing the crash somehow.

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....
17 minutes ago, Ipsquiggle said:

Awesome, that was the correct file and very helpful, thanks!

I'm putting in a fix so that this won't crash anymore.

However, would you be able to post your newest save file (note: it may be an autosave)? It seems like there's something about that file that's triggering the issue, and I'd like to make sure there isn't a deeper problem.

In any case, once the next patch goes live, this crash will go away. You can also work around it in the meantime by moving your newest save file out of the saves folder as it seems to be causing the crash somehow.

In reading through suggested solutions in other threads, I have since deleted all of my local files, including saves. Apologies!

  • Like 1

Share this comment


Link to comment
Share on other sites
....

I was also affected by this same issue.

I saved my game and my computer ran into a blue screen of death immediately after.

 

Every launch of the game failed with an almost identical error after I fired the computer back up.

I made a copy of the save folder, then overwrote the affected w/ my last autosave and I can launch the game again.

 

Attached is the affected save file.

Edit: Also noteworthy, this thing got stuck in my Steam Cloud so it was a bit of a pain to get rid of.

Every time I tried to delete the file, it kept getting re-downloaded on next launch. I had to overwrite the affected file to get the game to launch again, rather than deleting it.

The Chaotic Shelter-Starving.sav

Edited by NukeNPave

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now