Jump to content

Thermo Sensor not toggling [solved]

  • Branch: Live Branch Version: Windows Closed

Edit: Problem solved. User error, no bug.

As the title says, a thermo sensor isn't toggling when it hits temperature thresholds.

The first picture shows that the thermo sensor is trying to send a red signal. In the second picture, it clearly is still sending a green signal. It was working earlier, but has since stopped.



Green Prison.json

Steps to Reproduce

Load game file.

Unknown how to duplicate. Attempting to change the temperature on the thermo sensor doesn't result in any change. Tried deconstructing it then rebuilding. It didn't help.

User Feedback

This is an OR gate


When either of the inputs is green, it outputs green until both inputs are red.

When you connect the input of the OR gate to its output, it will get green and it will send green to the input. The input is overwritten and it doesn't work anymore


If there is no connection between input and output of the gate, it works fine

Edited by sakura_sk

Share this comment

Link to comment
Share on other sites

Ah, yes, thank you! I had rebuilt the thing and somehow connected it wrong. Spent 25 minutes trying to figure out what was wrong and somehow missed that. Sorry for the false report. Just user error on my part.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...