Suffocation / Failure to Move When Valid Path Exists


darkpoetcc
  • Pending

I recently had a duplicate that died from suffocation, when it had a valid path to exit.  I tried manual movement, clearing additional potential barriers, and even rebuilding part of the ladder for the dupe to escape.  However, it still remained in the same place until it died.  It would not even path a single block away.  However, the duplicate was not stuck "in the floor" like a number of other bugs I have found on the forum.  I have attached the entire gamefile set.

NOTE:  Reloading an autosave from the point right before the duplicate simply stopped responding to all commands did not have the same effect, although I made it even harder than the original scenario the "trapped" duplicate faced; reattempting the same scenario afterwards, the duplicate responded to commands and even worked to save itself, and suffocation did not occur, and was not repeatable.

NOTE:  I have included the save files; however, I had already restarted the game, and destroyed the output logs.  I will keep attempting to recreate the issue, and will update this post if I figure it out.

DeathFromSuffocation.zip


Steps to Reproduce
I was digging and placing an Algae O2 generator. When my duplicate was at the lowest point, where CO2 was the entire atmospheric layer, it stopped responding to commands. As noted above, reloading the same situation from an autosave point did not have the same effects; therefore, it is assumed to be a pathing glitch. When looking at viable paths via Show Navigation command, the duplicate (both times) had the same "shown" pathing options.


User Feedback


i have had similar issues when ive locked doors to prevent them going to contaminated areas, path shows them wanting to pick up a resource in the room but dupe just stands there at the door suffocating and wont repath or move when commanded to.

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now