Sign in to follow this  

substantial process and/or memory leak in current live branch


avc15
  • Branch: Live Branch Version: Windows Pending

My current base is at 2400 cycles and I have a LOT of systems. Lots of things going on. Conveyors, pipes, vents everywhere. All have a purpose.

Sticky Committee.sav

Loading this game and focusing on nearly any aspect of the base I run at a pretty smooth 24-30 FPS. After only a few hours of gameplay it slows to a crawl again, down to 10-15 FPS.

There is a process leak somewhere. It's more than just a memory leak. Process size gets a bit large but not beyond reason - performance drops dramatically.

Very encouraged by the optimization updates - keep up the good work!


Steps to Reproduce
Run a late cycle base with lots of builds for 300+ cycles straight at 3x speed

Status: Pending

This issue has not been confirmed by a developer yet.


  Report Bug
Sign in to follow this  


User Feedback


....

Check one thing. Im on cycle 1800. I think most of my CPU resources go to dupes cought in loops.

 

Could you please check if (all) your dupes are really working? Would be interesting.

 

I found loops in auto bottler, picking things up like steel (building)

Edited by eihns

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now