Jump to content

Soiled Suit status still affecting Dupe after suit removal

  • Branch: Live Branch Version: Windows Pending

Good evening.

This is a bug I recently encountered. I am a person that builds through a stream of consciousness, so I was used to stress increasing until things leveled out at the end of a project; perhaps to the point of easily glossing over it. I'm relatively new to this game, and was starting to segment some elements of my base to require atmo suit and checkpoints. I didn't like the first trial, so I removed all of the checkpoints, and started over. One thing to note is that I assigned the suits, before moving them to their docks. So I have new checkpoints. This leads me to my current bug.


My Dupe Nisbet is afflicted with the Soiled Suit stressor. The issue is that she no longer wears the suit, but her stress is rising extremely fast. I am not sure how this occured, but the following is what I did to troubleshoot solutions to trick the game back into normalcy.
1. Get her to put on one of the suits already lying on the ground.
- This resulted in her picking up a "ghost" suit. It wasn't visibly shown on her character, but Nisbet's information menu did have a button for her to drop the suit. She still had the SSuit status. Did not attempt to try again.
2. Going into Sandbox, and deleting all atmo suits and related buildings. Thinking it was maybe the status of a bugged suit that was still attached to her in spirit.
-No change.
3. Going into sandbox, dropping a fresh suit onto the ground, and telling Nisbet to remove it.

I have attached the save files of my first and second troubleshoot attempts. Hopefully something can be gleamed out of this. Please

Great game by the way. First week after Christmas and I had 40 hours logged. I work a 40hr job. Send help.




Steps to Reproduce
This was a bug that occurred outside my focus until the "High stress" alert showed. I'm afraid I do not know how this occurred.

User Feedback

EDIT: I attempted my first troubleshoot step again. It worked. No idea what happened with the original first troubleshoot step.
I also forgot to mention that Nisbet showering did NOT remove Soiled Suit.

Edited by Codubreku

Share this comment

Link to comment
Share on other sites

I'm currently having this bug on one of my dupes and I'm pretty sure how it happened.

In one the new "spaced out" DLC rockets I had two dupes in atmo suits, however the oxygen was running out on one of them, so I had the other dupe unequip her atmo suit and then let the dupe that is now having this issue equip it. It was only a few cycles later I noticed this one dupe having the "soiled suit" debuff.

I tried your option 1, without succes, I'll try reloading the save now, as I'd prefer not to use debug tools.


EDIT: Moving Nails past my atmo suit docks resolved the issue quite easily



Edited by MrJBlacc

Share this comment

Link to comment
Share on other sites

Yes, I experience the same issue. The soiled suit debuff won't get removed unless you move them past a atmo suit dock...

Share this comment

Link to comment
Share on other sites

I had the same issue, I tryed to force a dupe to equip a suit I found on the last planet or the dupe pissed in the rocket, I don't remember (I also couldn't make her equip the ***** suit) but I noticed back when she was at the home base, she had a soiled suit debuf and I had to make her equip an other suit to fix it.


Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...