Jump to content

Rocket wont land at all

  • Branch: Live Branch Version: Windows Fixed

I have tried to land my rocket after deconstruction and reconstruction of the landing platform but it bugs out and does not land. I cant even cancel the land from the platform and trying to change destination to planet does nothing. Please help my dupe survive lol. Save files attached.1803543916_ItsSPACEDOUTStartAsteroidesCycle211.thumb.png.a8bd033a7993298edd817936b86b70ab.png

Its SPACED OUT Start Asteroides Cycle 211.sav

Steps to Reproduce

I dont know how to reproduce this. Possibly an issue with the world seed or planet. Will try to play another colony on sandbox to try and reproduce this bug. Please send me an email if you need any  previous savefiles.

  • Like 1

User Feedback

A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

The rocket shouldn't be there image.thumb.png.c0e18c28c8971339fcb7f74d4283194b.png but you can still land it

Step 1:
Change destination to orbit
Let the rocket reach destination

Step 2:
Land the rocket by clicking "land here" on the rocket platform

Step 3:
Watch the rocket land

  • Thanks 1

Share this comment

Link to comment
Share on other sites

Thank you so very much ! It works now!

It was my first time using rockets on Spaced/Vanilla. I had no idea what I was doing tbh. 

Funnily enough I tried doing exactly this before I posted here, but it would just send the rocket to the image here and wouldn't let me land.


Share this comment

Link to comment
Share on other sites

The same thing happened to me.  Rocket reached the target planet, but did not land.  I was able to fix in the same way as described by sakura_sk, thanks.  Some observations:

  • The starmap bugged out.  When this happened, I couldn't see the ship at all on the starmap.  Save-reload caused the ship to re-appear, but on the target planet.  Inability to land persisted.
  • I had also changed landing pads, i.e. deconstructed my original landing pad, created a new one on the planetoid, so this may be why the rocket couldn't land.

Share this comment

Link to comment
Share on other sites

I had that very same issue. The issue might be caused by a second landing pad that i constructed while the rocket was already in-flight..

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...