Jump to content

Mask dock won't fill

  • Branch: Live Branch Version: Windows Pending

Oxygen wont flow to 2nd and 3rd dock.  Have reloaded, rebuilt pipe under 2nd dock, rebuilt 2nd dock, rebuilt pipe under first (working) dock.  Don't get what's wrong.  First dock pipe has 1000g of O2 connected to 2nd dock pipe which is empty.  This setup has worked for me before but not now.  Maybe I rebuild the entire thing.  



Steps to Reproduce

idk it has worked before.  I loaded the game this morning and it was the first I'd noticed it not working.  

User Feedback

Do you have a save file that has that problem? It could be some conflict in piping that makes pipes confused and oxygen doesn't flow.

Share this comment

Link to comment
Share on other sites

Yes, you are right. It seems like the inputs of oxygen masks don't act like drains like inputs of vents act but they act like T junctions. They let oxygen flow to the input only when it is coming from an output. But that happens only for the second oxygen mask dock in line. The first one fills up just fine.

I'm not sure if this illustrates and explains the problem/confusion well enough:


Although the input acts as a drain for the line of pipe if there is only one input, it doesn't let the pipe flow to the next one if there is no output. It's not only the oxygen mask docks that act like that. Every input if there is no output on one side will stop flowing.

I thought pipes didn't act like that but maybe I'm used to set pipe priority by using bridges that I didn't realize when/if their behavior without output changed

  • Like 1

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...