Game crash at startup


edaweu
  • Branch: Live Branch Version: Linux Pending

Game crashes before starting, during the Klei logo.

I'm running the latest stable version through Steam (autoupdates), game worked fine a around month ago, don't know which update that created this problem.

I'm using Debian 9.13, Kernel 4.9.0-15-amd64, Nvidia Driver 418.152.00

I have checked the integrity of the files, which downloaded a file of 64bytes, -still doesn't work

I have uninstalled through steam, then deleted all the files in the installation folder, reinstalled, -still doesn't work

I have added the "-force-glcore" in the launch options, -still doesn't work

I have uploaded the Player.log and a print of LSWH (username is replaced in the print)

Best regards, Erik


Steps to Reproduce

Startup



User Feedback


....

It sounds like a configuration issue with Steam. According to your log the issue is the game can't connect to the Steam API so the game closes as expected. This discussion suggests refreshing steam files might resolve it. Are you able to launch other games?

[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.

 

  • Thanks 1

Share this comment


Link to comment
Share on other sites
....

Other games work (i only have Cities Skyline, Broforce and Left 4 Dead 2 installed and all 3 worked, i don't have anything 'graphic heavy' to try)

I did the 'refresh files' from the linked discussion, which crashed my steam client and i had to reinstall it.

When the steam client was up and running it didn't see the games as installed so i deleted the game files manually and reinstalled the game through steam.

Now the game gets stuck at the logo screen and i have to alt-tab out of the game and kill it.

I have uploaded the current Player.log file

Player.log

Share this comment


Link to comment
Share on other sites
....

It sounds like the issue started when we updated the Steamworks SDK in the March 11th game update. The other games you mention are likely on an older version.

What is your Steam client version? You could try the Steam Client Beta to see if there's a fix for this issue.

This part of your Player.log is from the Steamworks SDK and I found multiple discussions about it dating back a few years. Some suggest its an issue with certain kernel versions, others suggest removing certain directories/configs would fix it. Not sure what to recommend trying here.

src/common/pipes.cpp (837) : fatal stalled cross-thread pipe.

 

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now