Sign in to follow this  

Game constantly crashing at a single marked point.


8BitMocha
  • Branch: Live Branch Version: Windows Pending

My game keeps crashing at a set point. It's definitely something to do with the Snazzy Suit but I can't isolate what mod it's conflicting with because none of them are clothing mods, it'd be nice to know. I DO know that if I have him unequip the suit before he reaches the tile the game crashes on, the crash doesn't happen. 

  at UnityEngine.Transform.set_parent (UnityEngine.Transform value) [0x00000] in <a35d771e78bd4d75a6f3aedeaad4d1ed>:0 
  at Equipment.Unequip (Equippable equippable) [0x00000] in <a8d8cafbcd164cda9f477d36796bfc75>:0 
  at Equippable.Unassign () [0x00000] in <a8d8cafbcd164cda9f477d36796bfc75>:0 
  at AssignableSlotInstance.Unassign (System.Boolean trigger_event) [0x00000] in <a8d8cafbcd164cda9f477d36796bfc75>:0 
  at Equipment.Unequip (Equippable equippable) [0x00000] in <a8d8cafbcd164cda9f477d36796bfc75>:0 
  at Equippable.Unassign () [0x00000] in <a8d8cafbcd164cda9f477d36796bfc75>:0 
  at Assignable.OnCleanUp () [0x00000] in <a8d8cafbcd164cda9f477d36796bfc75>:0 
  at KMonoBehaviour.OnDestroy () [0x00000] in <1dcc11867b524f7cb2488468843e982e>:0 

 

Is all it tells me. I'll upload my output log here too. My dupe just walks past the printing pod on his way to deliver some lumber to a wood generator. He walks past the super computer and it crashes as he passes it but I think that's irrelevant. 

output_log.txt


Steps to Reproduce

I'm not sure what's causing it or how to reproduce it at this exact point- He's been wearing the suit for maybe 20 cycles and no issues, and wood burner isn't too new either. I've uploaded my save at about ten seconds before it happens. 

The Scientific Abode.sav

Sign in to follow this  


User Feedback


.... .... ....
10 hours ago, Gurgel said:

AFAIK, the policy Klei uses is that you need to have issues with _no_ mods for them to take a look. 

Dang, well, it's now public so anyone else can IG. I have NO idea, never had bugs like this before. It's now crashing again, with the same error, just Atmo_Suit instead. 

And whatever it is, still crashes with the mods disabled, so it has to be like, a physical item mod. Oof. 

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now