Filter Outputs panel shows wrong element instead of no element


607581_1452789984
  • Branch: Live Branch Version: Windows Fixed

When you select a Gas Filter, the Filter Outputs panel opens, with a Filtered Gas Output sub-panel.

If this is a newly created Gas Filter, there is no element actually selected. Unfortunately, if you've already opened the Filter Outputs panel before during this play session, for a different filter, then the Filtered Gas Output list shows the old element selected! This is confusing and can lead to a player thinking that a gas filter is ready for action when it's actually not.

This is illustrated in the attached screenshot. Note that there are three different conflicting indications in that panel; it appears that Oxygen, Natural Gas, or "No element selected" could all be the actual selection. If the player is looking at the panel instead of reading the (smaller, unhighlighted) text above, they will be confused.

 

20190721162609_1.jpg


Steps to Reproduce
Select a gas filter. Build a different gas filter. Click on the second filter.

Status: Fixed

This issue has been fixed in either a future version or updated in a previous version.


  • Like 1
  Report Bug


User Feedback


A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.
....

Changed Status to Fixed

Finally squashed this one. Thanks for the report! :) It will be fixed in the next testing patch.

  • Thanks 1

Share this comment


Link to comment
Share on other sites


Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now