Jump to content

Critter Feeder delivery is in mgs

  • Branch: Live Branch Version: Windows Pending


Sometimes my dupes start to bug and only take out mgs from the fridge. On top of that the liceloaf then seemingly vanish into nothing (maybe they don't get taken out at all) since neither the dupe has it shown in his inventory nor does the feeder have the liceloaf when the dupe delivers them.
Reloading as well as changing the settings on the feeder fixes this temporarily.

Steps to Reproduce
Reproduction is random so I'd say best guess is to copy my setup: Critter Feeder with 2Kg storage Capacity set to Liceloaf priority 8. Refrigerator with Liceloaf priority 7.

User Feedback

I think I may've found the same bug or related. I'm on a Mac, OSX 10.14.1.

I just could not get my Dupes to load a Critter Feeder. This was in a No Sweat style game, with no Sandbox, and I ran into this circa Day 58 (in case any of that helps). I tried making the Feeder accept everything, I verified that I have plenty of material that could go into it, I cranked the priority up to 9, I disabled all priorities except Supply for all my Dupes, I built a second Feeder and cranked *that* one up to 9 too, and finally everyone went Idle without anyone ever appearing to attempt to fill the Feeder. (If I were having the exact same problem discussed above, I would have expected the Dupes to run around in futile little circles emptying all my storage containers one disappearing mg of sandstone at a time, but I didn't see any of that, they just ignored the Feeder completely.) To check for reproduceability, I also tried turning on Sandbox and spawning a Critter Feeder that way, for side-by-side comparison... and then they started filling *both* of them properly. I was also able to start a new asteroid, Sandbox in a Critter Feeder, and have the Dupes dig some Sandstone and load it; no problem. I only seemed to have any trouble with the hand-built Critter Feeder, and only prior to turning on Sandbox Mode at all. I also speculate that this is a fairly recent bug, possibly from the latest update; I've been playing since May and I've used Critter Feeders successfully several times without ever having encountered this problem before.

I hope this helps the developers catch the bug! I really enjoy this game, it's a pleasure to watch it grow, and you guys do great work.

Share this comment

Link to comment
Share on other sites

I've had it happen with both dupes delivering food (140 mg of meat from fridge to grill) and a sweeper arm doing the same thing (119 mg of raw egg from floor to grill).  In both instances it appears as if the grill has almost enough to complete a dish, so they are trying to get enough but do it in mg instead of normal amounts.  Even my Rock Crushing dupe with 16 Strength and +640KG carrying capacity is doing this, so I wonder if the grill/feeder itself is what's causing the problem.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...