Crash on enabling or disabling any mod


ScreamingPict
  • Branch: Live Branch Version: OSX Pending

I have an odd issue that I have had for some time now. It's not critical but I thought I should mention it.

Any time I enable or disable any mod and then click "restart", the client crashes instead of restarting.

On reloading the client the relevant mods are correctly enabled/disabled and the game works fine.

 

Crashlog: 

System.Diagnostics.Process.StartWithShellExecuteEx (System.Diagnostics.ProcessStartInfo startInfo) (at <d2957de1c3fd4781a43d89572183136c>:0)
System.Diagnostics.Process.Start () (at <d2957de1c3fd4781a43d89572183136c>:0)
(wrapper remoting-invoke-with-check) System.Diagnostics.Process.Start()
System.Diagnostics.Process.Start (System.Diagnostics.ProcessStartInfo startInfo) (at <d2957de1c3fd4781a43d89572183136c>:0)
App.Restart () (at <637357580a8642c6b23696d826324bd8>:0)
ConfirmDialogScreen.OnSelect_OK () (at <47301079f48644b6b6d2a70f0cc3df51>:0)
KButton.SignalClick (KKeyCode btn) (at <637357580a8642c6b23696d826324bd8>:0)
KButton.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) (at <637357580a8642c6b23696d826324bd8>:0)
UnityEngine.EventSystems.ExecuteEvents.Execute (UnityEngine.EventSystems.IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) (at <df908a91aa0f474f9f22637bf50e3fd3>:0)
UnityEngine.EventSystems.ExecuteEvents.Execute[T] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.ExecuteEvents+EventFunction`1[T1] functor) (at <df908a91aa0f474f9f22637bf50e3fd3>:0)
UnityEngine.EventSystems.EventSystem:Update()
 


Steps to Reproduce

1. Enable or disable any mod.

2. Select "restart"



User Feedback


There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now