Jump to content

Consistent crash within 30s after save

  • Branch: Live Branch Version: Windows Fixed

(I'm sorry, can't remember which branch is live and which is preview (these words mean the same to me) I'm on the "more-stable" early access branch, the one updating every few weeks)


The game crashes consistently about 5 seconds after the save with:


ArgumentOutOfRangeException: Index and count must refer to a location within the buffer.
Parameter name: bytes

System.Text.UTF8Encoding.GetString (System.Byte[] bytes, System.Int32 index, System.Int32 count) (at <695d1cc93cca45069c528c15c9fdd749>:0)
FastReader.ReadKleiString () (at <8e85aab05d1d44a5b339d82e5aea3b88>:0)
StateMachineSerializer+Entry.Restore (StateMachine+Instance smi) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
StateMachineSerializer.Restore (StateMachine+Instance instance) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
StateMachineController.Restore (StateMachine+Instance smi) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
StateMachine+Instance.StartSM () (at <c8af1c7577924b4e8159a8d1b7565399>:0)
StateMachine`4+GenericInstance[StateMachineType,StateMachineInstanceType,MasterType,DefType].StartSM () (at <c8af1c7577924b4e8159a8d1b7565399>:0)
GameplayEventInstance.StartEvent () (at <c8af1c7577924b4e8159a8d1b7565399>:0)
GameplayEventManager.StartEventInstance (GameplayEventInstance gameplayEventInstance) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
GameplayEventManager.RestoreEvents () (at <c8af1c7577924b4e8159a8d1b7565399>:0)
GameplayEventManager.<OnSpawn>b__6_0 (System.Object obj) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
Scheduler.Update () (at <c8af1c7577924b4e8159a8d1b7565399>:0)
GameScheduler.Update () (at <c8af1c7577924b4e8159a8d1b7565399>:0)

Build: U37-484114-SD

Steps to Reproduce

Serene System 7b.sav

User Feedback

A developer has marked this issue as fixed. This means that the issue has been addressed in the current development build and will likely be in the next update.

Sometimes the error is a bit more descriptive:


NullReferenceException: Object reference not set to an instance of an object

Rottable.RefrigerationLevel (IRottable rottable) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
Rottable+Instance.RefreshModifiers (System.Single dt) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
Rottable+Instance.Rot (Rottable+Instance smi, System.Single deltaTime) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
Rottable+RotCB.Update (Rottable+Instance smi, System.Single dt) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
UpdateBucketWithUpdater`1[DataType].Update (System.Single dt) (at <8e85aab05d1d44a5b339d82e5aea3b88>:0)
StateMachineUpdater+BucketGroup.AdvanceOneSubTick (System.Single dt) (at <8e85aab05d1d44a5b339d82e5aea3b88>:0)
StateMachineUpdater.AdvanceOneSimSubTick () (at <8e85aab05d1d44a5b339d82e5aea3b88>:0)
Game.SimEveryTick (System.Single dt) (at <c8af1c7577924b4e8159a8d1b7565399>:0)
Game.Update () (at <c8af1c7577924b4e8159a8d1b7565399>:0)

Build: U37-484114-SD

I've tried emptying all my fridges to see if that reset a counter or something, but to no avail.

Share this comment

Link to comment
Share on other sites

These are for the second error, but I suspect the first error is something else.

Edited by AyCe

Share this comment

Link to comment
Share on other sites

Thanks, this fix was exactly what I needed. I "emptied" a playload with nearly spoiled food inside, and the crash is solved.

Share this comment

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...